12 Replies Latest reply on May 14, 2015 4:38 PM by archiebald

    HD Driver setup language

    Alexei Jolkin


      I run w7 HP x64 enUS but I am located in Sweden therefore must have some local swedish settings, like the keyboard, a default non-unicode language etc.

      I have English as default screen and system language, and I want all programs and drivers to have English interface.

      And I manage all programs in English eccept for the Intel HD Graphics driver.

      Even though I run fully manual setup and force the damn thing to be installed in English, like that:

      "setup -b -overwrite -nowinsat -l 0409"

      I still get parts of the menu in Swedish, and parts of the menu in English and it tells me in System Information that my Default Language is Swedish.

      ??????

      How difficult could it be to let the user to decide which language he or she wants to run the application???? Why the things need to be automatically wrong these days?

      Besides, the description of the installation switches is faulty. The switch "-l0409" (according to the description) won't be accepted, but "-l 0409" would run OK.

      I am deeply disapointed in this product (Intel HD Graphics 4000). Also, I can't get it running with a primary screen on HDMI output, but it is a different story for a different thread.

        • 1. Re: HD Driver setup language
          allan_intel

          Hi,

           

          The latest Multilanguage driver looks at the language of the operating system to know in which language to display the information.


          You will need to change the language in which the operating system is set for the driver to be displayed in the desired language.


          In other words, the language of the graphics properties will follow the language of the operating system.


          The following link contains related information to switch language in the Graphics control panel:


          http://support.intel.com/support/graphics/sb/CS-021334.htm

          • 2. Re: HD Driver setup language
            nic

            Hi Alexei,

             

            You said you have your keyboard set to Swedish; what do you have your 'Display Language' set to?

             

            To check (you probably already know this!).  Hit Start -> Control Panel -> Clock, Language and Region -> Change Display Language -> Select 'English' as display language.

             

            The Intel® Graphics and Media Control Panel™, as Allan stated - is following the display language you have selected as the OS's display language.

             

            Let me know if this fixes the issue or not,

            -Nic

            • 3. Re: HD Driver setup language
              Måns Tånneryd

              I have a similar problem and I must say that this is enormously irritating. I live in Sweden and I prefer to use a Swedish keyboard and Swedish regional format settings. But, this does NOT mean that I want context menus and applications translated to Swedish. If I wanted Swedish as the default language I would have installed the Swedish version of Windows, but I did NOT! Having mixed languages in the context menu on the desktop after installing intel Graphics drivers drives me nuts. I have tried to set everything I possibly can to English, even used the L and l switches in the setup programs but the Swedish menu alternatives still show up!

               

              I'll keep trying and post again if I ever figure this out.

              • 4. Re: HD Driver setup language
                nic

                Hello Måns,

                 

                What driver version are you experiencing this problem with?  You have an English operating system installed, and it  displaying in Swedish?  What if you change the regional settings to English - still Swedish then?

                 

                Thanks,

                -Nic

                • 5. Re: HD Driver setup language
                  auqa

                  How I sloved!

                   

                  1. extract INTEL DRIVER with WINRAR

                  2. in my case is the Arabian language problem

                  3. I have deleted Arabian language files from extracted folder, my case this one Gfxres.ar-SA.resources

                  4. renamed Gfxres.hr-HR.resources to Gfxres.ar-SA.resources

                  5. then with install, once again deleted igfxrara.lrc

                  6. once again renamed croatian to igfxrara.lrc

                  7. and I have language that I want

                   

                  A perfect solution, not bios update like other forum says.

                  No modification microsoft framwork, no other setting languages in the windows touched.

                   

                  Just simply and working nice!

                   

                  thanks and I waiting new driver 

                  • 6. Re: HD Driver setup language
                    embera

                    Hi,


                    I live in Hungary and I use Windows and all applications in English, because Hungarian translations for applications are beyond horrible and I have always used programs in English. Unfortunately I have to set the locale for non-Unicode apps to Hungarian, because some applications won't work with unicode files containing special Hungarian characters (like "ő", "ű"). I had the same problem with Intel Driver and I was really disappointed, because Intel thinks that the users of their driver are all lamers so "the language must be set automatically".

                     

                    I tried what auqa wrote and it worked. I didn't have any *.resource files, just *.lrc files. I have overwritten \Graphics\igfxrhun.lrc by \Graphics\igfxrenu.lrc. Then reinstalled the driver from the extracted and modified files.

                     

                    Great solution, auqa!

                     

                    Thank you very much, you saved my day.

                     

                    Shame that these software can be released in the 21st century while a small, low-cost software modification could enable customizable language.

                    • 7. Re: HD Driver setup language
                      Nick_Q

                      Same situation as described above. Windows 8.1 Professional 64-bit. System language set to English (United States). I live in Russia (sorry for that) and I HAVE to set Date, Time and Number formats to Russia (Russian) otherwise some applications don't work properly. Every application that doesn't have an option to choose menu language during installation (or in its settings thereafter) displays menus in English, even the Russia-specific ones. With the only exception. Guess what? Don't you think it's NOT smart not to let a user choose a language during the installation? I don't want to unzip/zip your install package removing language packs as suggested by another disturbed user. So I'm requesting YOU to provide me with a link to the driver package which doesn't contain ANY other language than English (United States). That's not my work, folks. I paid for my i7-4790K in order to use its built-in graphics and not to waste my time on REPAIRING your software that has too many issues aside displaying menus in a wrong language.

                       

                      I need a generic Intel HD Graphics 4600 Driver ver. 15.36.7.64.3960 (10.18.10.3960) for Windows 8.1 64 bit. Compatible with my Intel Core i7-4790K. Thank you.

                       

                      Please note that if I change Date, Time, and Number formats to German (Germany) keeping the system language as English (US), after reboot I see menus in German, if I set the value to Russia keeping the system language as English (US), Intel menus are in Russian. Funny game? And that's not a hypothetical example. I DO need to switch Date, Time, and Number formats to German, English, and back to Russian on a regular basis ALWAYS keeping English (US) as the System Language. It's a software bug, never a feature.

                      • 8. Re: HD Driver setup language
                        Nick_Q

                        Anybody from Intel reading the thread, please?

                        • 9. Re: HD Driver setup language
                          raybk

                          I really hate software trying to pretend to be intelligent to pick language for user.

                          It just causes annoyance to user! Like me who live in Hong Kong which use both English and Chinese. I need to set Windows to HK location in order to display Chinese in some applications. But, I really need my user interface to display in English!

                          Is it really so difficult to let user select a language?

                          • 10. Re: HD Driver setup language
                            M1hai

                            This is for the new Intel HD Graphics Control Panel

                            so go to C:\Windows\System32\ find files that end in .cui like this example: resROM.cui (this is language file for romanian), now I don't want to change my System Locale because romanian has special characters like ă,î,ș,ț and so on.

                            So find the res###.cui file corresponding to your language and remove it...than rename resENU.cui to your language. Example: if you had korean: resKOR.cui remove it and rename resENU.cui to resKOR.cui, and that is it!! No restart needed the changes will take place instantly.

                            DO NOT FORGET to rename resENU.cui to your language otherwise all comands from Intel Graphics will become: "Cannot load string"

                            • 11. Re: HD Driver setup language
                              SaD4E

                              M1hai, does this work in Win 8.1? Can't find any .cui files.

                               

                              Intel Graphics Control Panel should use system OS's language. And maybe add a setting in Control Panel to change this language if needed.

                              • 12. Re: HD Driver setup language
                                archiebald

                                I know this is old but I recently had the same frustrating problem with Intel bluetooth drivers in WIndows 8.1 on a Japanese purchased tablet that I have converted to English.  Nothing I could do would persuade it to install in English.  After a huge amount of research including reading and trying the ideas in this thread I found the solution.

                                 

                                The intel drivers use the registry key "InstallLanguage" to set the language for its msi files installation.  The key is set according to the originally installed OS so even changing locale, date format, language packs etc won't change it.

                                 

                                Registry path is HKLM\SYSTEM\CurrentControlSet\Control\Nls\Language\

                                 

                                In the end, all I had to do was change the value from 0411 for Japanese to 0409 for English US or 0809 for English UK, then the Intel drivers installed with all information in English, including the advanced properties in device manager.

                                 

                                You can find a usable list of language codes here Locale IDs, Input Locales, and Language Collections for Windows XP and Windows Server 2003

                                 

                                Hope this helps someone!!