1 Reply Latest reply on Nov 17, 2012 12:23 PM by Barry Johnson

    PCI out of resources error following BIOS update (51;25;22) on S3420GPLX

    Barry Johnson

      Hi all,


      I've just been on to David at Intel support in the US who I've run through this with and have an open case for this under 8000548728. However, I thought I would post this up on the off chance that someone has come across this error as well and found a workaround. Essentially, I've been happily using the Matrix RAID Controller with another PCIe RAID Controller (Highpoint RocketRAID 2720) for months. However, today I was finally going to resolve the video socket issue I've been having with the RMM3 card and decided to upgrade to the latest version of the BIOS available for the motherboard (release notes available here: http://downloadmirror.intel.com/21517/eng/release.txt). However, following the BIOS update and managing to resolve the RMM issue, I've now been presented with an even worse one as I now cannot get the Matrix RAID card to start. In Windows, it shows a warning in Device Manager stating "The Device cannot start (Code 10)". In the Error Manager tab within the BIOS, I have an error code; 146, severity; Major & Instance; N/A entry. The description here shows "PCI out of resources error".


      I've already established with David that the issue is in some way related to the PCI resources available and that there may be a potential conflict between the Matrix RAID Controller and the RocketRAID card. However, what I don't understand is how an updated (and apparently improved??) OPROM can cause such an issue? So far, I've tried the following:


      1. Disabling the Serial Ports in the Advanced settings to try to free up resources.
      2. Setting the Memory Mapped I/O above 4GB option to Enabled
      3. Replacing the card in any other slot than the default (Slot 5, Gen2 x8 Connector)
      4. Disabling the NIC ROMs for one or both NICs to free up resources
      5. Resetting and clearing the CMOS (AC power off, battery removal etc.)
      6. Re-flashing the BIOS from the EFI console


      Nothing above has worked. I can basically boot from the SSD attached to the RocketRAID Card and still run the VMs stored on the SSD's in RAID 0, but these are also attached to the RocketRAID card. Any combination removing the card will result in me not being able to access my VMs which isn't really a great option either.


      I could really do with some guidance on whether any of the following are possible/may help:


      1. Reinstalling the operating system using the EFI options within the BIOS (what are the benefits/drawbacks of using an EFI option over BIOS?)
      2. Manual resource allocation to ensure all controllers are happy and have resources (can this be done via EFI somehow? Another utility?)


      Please can someone in the know lend a hand here as I've been in IT for a while, but this has run my ideas pool dry.


      Thanks in advance,



        • 1. Re: PCI out of resources error following BIOS update (51;25;22) on S3420GPLX
          Barry Johnson

          Well, both disappointed and unsurprised by the fact that Intel in the UK didn't even bother to action the callback requested by the US this week, I decided to review another plan instead. The fix to this issue is move away from a rubbish RAID card and use the ESRT2 option instead of the Matrix RAID. No resource issues to speak of, however no RAID 5 option. I then decided to do a bit of research anyway about RAID 5 as this controller was already responsible for one huge data loss when I used RAID 5 but this near miss was the last straw. If you're using RAID 5 with three disks, consider the following research: BAARF - Battle against any raid 5 | www.oaktable.net, baarf.com, & RAID 5 vs RAID 10: Recommended RAID For Safety and Performance. If you can't be bothered, let me summarise (yes, with an 's' because I'm British) it for you:


          • RAID 5 writing is slower than RAID 10 because of the need to generate parity strips
          • RAID 5 is arguably less fault tolerant because any two drives failing in a RAID 5 array would cause total failure. RAID 10 could theoretically tolerate two failures in a minimum four disk array and still retain the data
          • RAID 5 read performance is also not as fast as RAID 10 because all four disks can be operated independently to read ahead
          • Disks today even after the floods are not as expensive as when RAID 5 was really considered an option for small & medium businesses to get the greatest fault tolerance to usable disk space for their requirements (n-1; see Standard RAID levels - Wikipedia, the free encyclopedia for more information). There's no longer the excuse "it's so much more expensive than a RAID 5 array". Ask yourself this, if your data is in a RAID array, how valuable is it to you? Less than the price of another drive? If so, why are you even creating a three drive array and losing a third of the usable space to redundancy??


          Given the fact I was able to pop the additional card out, swap the boot disk over to the Matrix RAID controller temporarily and rescue my data to a number of disks (thanks to the awesome speed of gigabit ethernet), I then took the plunge and decided to use the hot spare I had sat on the Matrix card as the fourth drive for a RAID 10 array. The results have been staggering. I'm now enjoying at least four times the performance, fewer errors during the nightly windows backup and peace of mind that ESRT2 has better monitoring features than Matrix RAID so for anyone who experiences the same issue, this is the fix. Don't wait for Intel to respond as the hardware will be obsolete before they do; just workaround and swap to ESRT2. If you insist on still needing RAID 5, order the AXXRAKSW5 key and move away from the Matrix option.


          To Intel support - thanks for nothing once again. I'll continue to rely on Google, seriously intelligent folks who help people where you can't and supply answers if and when I find any to problems I have.