5 Replies Latest reply on Nov 5, 2012 5:22 PM by AKB

    DZ77BH-55K & Linux UEFI

    AKB

      As we know -at least the people that made the mistake to buy this mobo- the UEFI is not supported on Linux. It has a irq misrouting firmware bug which intel doesn't seem to care about and also UEFI has been troublesome at least up until 0085 FW. Haven't tried  0091 &0093. Only 0057 worked right and booted linux (Ubuntu, Arch).

       

      Could anyone confirm that this motherboard will boot linux -as the only OS- with UEFI and the latest firmware.

        • 1. Re: DZ77BH-55K & Linux UEFI
          Shaun

          install the latest BIOS 0093, haven't had a single issue, I was running Mac OSX (Linux based) without issue.

          Only Problem I have is cosmetic, Power LED flashes if "FAST BOOT - General Optimizations" is enabled.

          Also I at first had lots of issues with this mobo, but now I would recommended to anyone, Intel has finally made some progress with Bios updates that have eliminated most issues.

          • 2. Re: DZ77BH-55K & Linux UEFI
            AKB

            Yes i installed the 0093 and it boots (period). The new problem is that efibootmgr cannot create boot entries and i am not able to boot the damn thing unless i use an EFI shell cd or usb.

             

             

            The irq thing its still there. If you boot with irqpoll as a parameter it goes away but makes the kernel take longer to boot.

             

            Come on intel engineers. Get your stuff together.

             

            PS.

            (Max OS x is not linux based)

            • 3. Re: DZ77BH-55K & Linux UEFI
              AKB

              To add to the above entries created with bcfg from an efi-shell also don't appear in the boot menu.

               

              I would appreciate it if an intel tech gave me a solution to this problem.

               

              I can see that the entries are written in NVRAM both with efibootmgr and bcfg but the boot menu seems unable to read them.

              • 4. Re: DZ77BH-55K & Linux UEFI
                Shaun

                Mac OSX is Unix based, just like Linux.

                • 5. Re: DZ77BH-55K & Linux UEFI
                  AKB

                  Just wanted to add that with 0094 firmware the problem with the NVRAM entries is STILL THERE. They don't appear on the boot menu.

                   

                  Also the irq missrouting problem is there and this should be fixed. Its a firmware bug that intel engineers dont seem to care.

                   

                  @shaun

                  Unix like and unix can be worlds apart but anyway.