10 Replies Latest reply on Mar 4, 2013 10:48 AM by Dennis Hammock

    DZ77RE-75K mouse doesn't always work in bios

    splautz

      I noticed that sometimes when I hit F2 to enter bios as the computer is booting up my mouse would be locked up (frozen in center of screen) after getting into bios.  Keyboard always worked fine.  After awhile I began to realize that this only happens when I do a Windows restart to get into bios instead of shutting the machine off first.  If I shutdown first (or after doing a CTL-ALT-DEL while in bios after experiencing a frozen mouse), the mouse is detected and works fine when I then enter bios.   I tried the mouse on both black USB2 ports and both have the same effect.  Anyone know if this bug is being addressed?

       

      My configuration:

      Intel DZ77RE-75K (bios 53)

      Intel 3770K

      16GB ram (2 x 8GB dual channel)

      Windows 7 Ultimate 64bit

      HDMI to DVI into monitor at 1920x1200 @ 59hz

      USB Microsoft optical wheel mouse

      PS/2 Microsoft keyboard

        • 1. Re: DZ77RE-75K mouse doesn't always work in bios
          Dan_Intel

          Hi splautz,

           

          We would like to inform you we don't have any reports of keyboard issues so far but in the mean time our recommendation is testing with a different USB keyboard just to narrow the issue. You can also clear the CMOS battery for 20 minutes and restore defaults in the BIOS.

          • 2. Re: DZ77RE-75K mouse doesn't always work in bios
            splautz

            This isn't a keyboard issue.  My keyboard is a Microsoft PS/2 keyboard and it works flawlessly in the bios.  The issue is the USB Microsoft mouse, which doesn't work under one unique condition.  And that's when I issue a restart in Windows and then hit F2 to get into bios as it is restarting.  The pointer is there in bios but it is frozen.  If I unplug the usb mouse and plug it back in, bios will then sense it and it'll begin to move.

             

            The mouse works fine when entering bios after hitting the power switch or doing a power cycle (shutting it down first and then powering it back up).  It also works if I hit CTL-ALT-DEL while in bios after experiencing a frozen mouse.  When entering bios the 2nd time it works, so in this case like unplugging it, a full power-down is not needed to get it to work.

             

            The mouse works flawlessly in Windows.  It just seems as if bios cannot get control of the mouse again very easily once Windows had a chance to take control of it.  It's weird because I'd think a restart would clear all that.  I'll try some more tests with it, e.g. without a keyboard even plugged in or with a different usb mouse, and report my results.

             

            To be honest, the issue isn't all that serious for me to go through the hassles of pulling my CMOS battery or even resetting my bios settings over.  I just know I have to shut down first before going in bios or, if I forget, hit CTL-ALT-DEL and then go back in.

            • 3. Re: DZ77RE-75K mouse doesn't always work in bios
              splautz

              I tried everything, including trying different mice, reloading bios defaults and updating to the latest 58 (microcode 13) bios just released on Oct 30.  The USB mouse is still frozen in bios after this sequence of events: Initiate a RESTART in windows and then hit F2 during POST to get into bios.  The mouse works fine under all other ways of entering bios, including right after a full powerdown and with the BACK2BIOS red button pressed (even after a windows restart).  The mouse works flawlessly entering by these methods, so I'm at a loss what is causing this problem, especially if no one else is seeing the issue too.

               

              A correction to my initial post:  The mouse does not get unfrozen by unplugging and plugging it back in while in bios.  Another reboot (CTRL-ALT-DEL) is necessary to get it to work.

               

              As a side note, after upgrading to bios 58 (microcode 13) I noticed a new bug.  The "Boot Drive Priority" list within bios is blank now, stating only "No boot drive".  When I go into SATA options, I can see all the drives listed by their respective ports and the machine boots up just fine, so I know bios can actually see and detect the drives.  There's just some kind of new bug starting with this bios revision involving displaying the boot drive priority list.  After extensive testing, I noticed the list came up fine after entering bios though BACK2BIOS.  After even more testing, I found by disabling (or removing the check by) "General Optimization" in boot options, the bug goes away entirely.   However, this did not solve in any way the "frozen mouse after a restart" issue unfortunately.

              • 4. Re: DZ77RE-75K mouse doesn't always work in bios
                eelliott

                I just built a DZ77RE-75K system and have the same difficulty with the mouse not working while in the BIOS after a restart from Windows 7 x64.  I have to either power off the PSU or Ctrl-Alt-Delete out of the BIOS to get the mouse to work upon re-entering the BIOS.  This behaviour is consistent -- like your experience, the mouse cursor is always frozen in the center of the BIOS screen after a restart from Windows.  And the mouse works perfectly once booted into Windows.

                 

                o BIOS version 0060.

                 

                o Mouse is a Logitech G700 wired to one of the motherboard's rear panel USB 2.0 black ports.   I am not using the G700's included wireless receiver.

                 

                o Keyboard is a Microsoft connected to the PS/2 port.  It's interesting that you also have a Microsoft keyboard.  Mine is an old Microsoft Office Keyboard.

                .....o Because of Microsoft's poor design choice, I have to press the keyboard's F-Lock button before I can press F2 to enter the BIOS.  It's unlikely but I wonder if this puts the keyboard into a state which interferes with the mouse.  Do you also have to press F-Lock on your Microsoft keyboard?

                .....o (I have used a Microsoft Office Keyboard on of all my desktop computers since 2004 and they must be connected to a PS/2 port for full functionality.  I have 6 of these keyboards.  So if these keyboards are the cause of the mouse difficulties and Intel cannot fix the problem, I'll just live with the Ctrl-Alt-Delete inconvenience.)

                • 5. Re: DZ77RE-75K mouse doesn't always work in bios
                  splautz

                  I'm glad to see someone else has confirmed this is happening to them as well and it's not just my motherboard.  That saves me from the hassle of returning it only to find out it was in the design or bios.   But maybe its in the hardware revision of our boards?  Anyway now since we've confirmed it's not just my board, let's see what we have in common here.  We both are using our keyboards on the PS/2 port and they are both Microsoft.  We both are using one of the black USB2 ports for the mouse.  It doesn't matter which of these I use, they both have the same result.  And it doesn't appear to matter which brand of mouse, I've tried a Microsoft and a wireless Logitech, both have the same result, and now you've confirmed a wired Logitech gaves the same result.  Now to the keyboards..  We both have Microsoft PS/2 keyboards, however mine is different and doesn't require F-lock.  I can push F2 right after power-up to enter bios, although sometimes I have to push it repeatedly to make sure I hit it at the right moment since I have quick boot enabled, no prompt or graphics on my POST screen.  My keyboard is the ergonomic split key variety.  Also, I believe I tried an older Dell PS/2 keyboard as well and the frozen mouse remained.

                   

                  At this point, I believe the issue might be more related to using a PS/2 keyboard with a USB mouse...  don't most have USB keyboard and mice nowadays?  Maybe that's why others rarely see this problem.  Also, the Intel guy recommended I reset my bios settings to default to try to clear the problem.  I tried that with no luck.  He also recommended I pull the bios battery to reset everything.  I've not had a chance to try that, but I don't see how that would change anything UNLESS the issue is related to doing a bios upgrade.  The very first thing I did to the motherboard after installing was upgrade the bios, so I'm unsure if the problem existed with the initial bios that came with the board.  Did you have a chance or remember if the issue happened with yours before you did the first bios upgrade?  If it happened with yours before the upgrade, I think that just about rules out this being a corrupted bios config caused by upgrading.  If not, one of us will need to totally reset our configuration by pulling the battery just to rule out that possibility.   I'd hate to have to pull that battery EVERY time I did a bios update.

                   

                  Also I noticed with bios 60 that even powering down the PC using the Windows shutdown command, or front button, will give a frozen mouse once I power it back up and enter bios.  I don't recall if totally removing all power will net the some results or not (by unplugging it or hitting the back switch).  But one thing is for sure, using the BACK2BIOS button seems to always consistently allow the mouse work, even if done directly after rebooting out of Windows.  Maybe that totally kills all power to the board before power cycling it.

                  • 6. Re: DZ77RE-75K mouse doesn't always work in bios
                    eelliott

                    I remember that the first time I booted the mouse worked fine.  I did not not change any settings, then rebooted and did an F7 BIOS update to 0060.  After the BIOS update I booted into the BIOS and changed some settings -- stuff like disabling the onboard audio but no performance changes.  After those changes POST hung repeatedly on 0x92 ("Detecting the presence of the keyboard"). I tried a USB keyboard but the 0x92 problem remained.  Ultimately I reconnected the Microsoft Office Keyboard to the PS/2 port and set the Jumper Block (p. 61) to pins 2-3 to clear the CMOS.

                     

                    My DZ77RE-75K was built 2012.05.30 so came with a very old BIOS.  The original BIOS was in the 3x or 4x range.

                    Intel1 CPU-Z motherboard.PNG

                    I did some more testing:

                    .....o I cannot enter the BIOS when the keyboard is connected via one of the motherboard's black USB 2.0 ports, i.e., apparently POST is not recognizing the F2.

                    ..........o Legacy USB support is Enabled (p. 71 of motherboard manual ("TechProdSpec")) so USB keyboards and USB mice should work.

                    ..........o All keyboards work fine once Windows is running.

                    ..........o I tested with three keyboard models:

                    ...............o Microsoft Office Keyboard

                    ...............o Genius LuxeMate i200

                    ...............o Adesso WKB-4200UB wireless

                     

                    .....o POST does not recognize F2 from the Genuis LuxeMate i200 even when the keyboard is connected via the PS/2 port.

                     

                    .....o Similarly I tried to connect the Adesso's wireless USB receiver to the PS/2 port.  I hot-swapped (unplugged Microsoft keyboard and plugged in Adesso receiver) while in Windows and the PC immediately shut down (no messages -- just instantly powered down) and it would not POST (nada, like it was dead except the LED's were lit).  Turned off/on the PSU and nothing other than the LED's would light. Would not initiate the POST process. Unplugged the Adessor receiver, reconnected the Microsoft Office Keyboard, powered on, and everything was OK again.  Whew!

                     

                    Obviously, something is not right with the Intel BIOS 0060.  While the workarounds to get the mouse working in the BIOS are a bit of an inconvenience, they're livable.  The bigger concern is the fragility of getting into the BIOS, i.e., will only certain keyboards and only when those certain keyboards are connected to the PS/2 port permit entry to the BIOS?  This could become a major issue if in order to enter the BIOS the user must use the Jumper Block and CLEAR ALL SETTINGS IN ORDER TO VERIFY SETTINGS OR TO CHANGE ONE SETTING.  But if users were experiencing results like my testing above, the motherboard would be next to unusable -- as you pointed out, most users probably are connecting keyboards via USB ports.  Newer keyboards probably do not need to be connected to the PS/2 port (like the Microsoft Office Keyboard does) to be fully functional.  The results above cannot be typical.

                     

                    I was thinking of buying a second DZ77RE-75K next week to replace another PC, but I'll have to mull it over some more.  I've been an Asus motherboard user for a decade but recently had to RMA the same Asus motherboard twice in a year.  So I decided to give Intel a try -- perhaps Intel's design quality and build quality would be more robust.  But these BIOS issues seem pretty basic -- sure, Asus also has to issue BIOS updates, but I don't recall an Asus update for basic stuff like keyboard and mouse handling.

                     

                    And, like you, I'm wondering if we got bad boards.  I bought mine from Amazon and have about 3 weeks left to return it.

                    • 7. Re: DZ77RE-75K mouse doesn't always work in bios
                      rbmorse

                      I use a Logitech T650 wireless trackpad on my -70K, and my experience is that different versions of the BIOS seem to recognize different USB ports during POST, but you also have to make sure the "quick boot optimization" option for USB ports is disabled in BIOS setup, too. If the quick boot optimization is set the board does not initialize the USB ports during POST. This is documented behavior.

                       

                      I normally disable all the quick boot optimizations because they don't save that much time, and each seems to introduce its own brand of odd behavior.

                       

                      Once the quick boot optimizations are disabled, try placing the receiver for your wireless device in a different port. For example, my T650's receiver works in the USB 3 ports on the back panel with BIOS 60, but it does not work in one of the USB2 back panel ports.

                       

                      Regarding the PS/2 port...there is an option in BIOS setup to disable the PS/2 port.  I believe the default is disabled...which seems to me to be a poor choice on Intel's part...but in any case ensure the port is enabled (and save configuration, exit setup and power off) before you connect a device to the rear panel PS/2 port.

                      • 8. Re: DZ77RE-75K mouse doesn't always work in bios
                        eelliott

                        My settings were already set as you recommend: Boot Optimizations = Disabled and PS/2 = Enabled.

                         

                        I had already tested the mouse connected to a USB3 port, rather than USB2 port, but the mouse still did not work in the BIOS when restarting from Windows.  However, you motivated me to test the Genius LuxeMate i200 wired keyboard connected to USB3, rather than USB2, and I was able to enter the BIOS -- as noted in my earlier post, F2 was not recognized from any of the three keyboards tested when connected to the motherboard's black USB2 ports.

                         

                        I also took your advice on saving the BIOS settings.

                         

                        Thanks for the tips.

                        • 9. Re: DZ77RE-75K mouse doesn't always work in bios
                          splautz

                          I was able to resolve my "mouse frozen in bios after Windows restart" issue by simply plugging the mouse into a blue usb3 port instead of one of the black usb2 ports.  I'm not sure why this works, but it does.  I tested it in bios 60, but now I'm using bios 61.

                          • 10. Re: DZ77RE-75K mouse doesn't always work in bios
                            Dennis Hammock

                            Enter the BIOS setup. Select Advanced Setup - Devices & Peripherals and disable (uncheck) USB 3.0 Hub Presence. This will fix the mouse not working in BIOS setup when you do a soft reboot. It might disable a couple of USB 3.0 ports, not sure about that.