3 Replies Latest reply on Nov 4, 2012 10:20 PM by splautz

    Intel HD 4000 Graphics (i7-3770K) blocking/flicker

    splautz

      In some fast motion games and video I notice "blocking" as objects move rapidly across the screen.  This can be best described as one section of the screen updating milliseconds faster/before other parts.  The easiest way to replicate or see the issue is in Civilization V.  Just zoom into your empire's map as close as it allows and then move your mouse rapidly to pan horizontally over clouded (unexplored) areas.  You will see shaky blocking occurring at the cloud boundaries.  It is most noticeable between light and dark areas of fast moving video and is not just limited to that one game.  I've seen it others as well especially video/movie clips displayed within games.

       

      I'm not sure if this is related, but there is also frequently a flickering effect when logging into Windows 7 itself as the screen fades in.  Just hit Windows-L to lock, then log back in.  After the screen fades out and back in, you can see its not always a smooth fade transition as the screen brightens back up.. it's blocky or full of noticeable lines not all the same shade during the fraction of a second as the fading-in happens.

       

      Anyone else experience or notice any of this?

       

      My configuration:

      Intel DZ77RE-75K (bios 53)

      Intel 3770K

      16GB ram (2 x 8GB dual channel)

      Windows 7 Ultimate 64bit

      HDMI to DVI into monitor at 1920x1200 @ 59hz

        • 1. Re: Intel HD 4000 Graphics (i7-3770K) blocking/flicker
          joe_intel

          Try to test with the latest or a different graphics driver version; especially if the issue does not happen in safe mode when locking windows. Loading the correct monitor driver is also recommended if it appears as “Generic PnP Monitor” in device manager.

           

          Based on your configuration it could also be hardware, caused by the HDMI to DVI adapter. Try a direct connection and test the monitor and cable. You may want to make sure the system is not overclocked.

           

          If the issue persists only with the game it could be related to Vertical Sync.

          • 2. Re: Intel HD 4000 Graphics (i7-3770K) blocking/flicker
            splautz

            1. A month ago when I built this system, I was using the older HD 4000 drivers available at the time.  I then upgraded to the latest which were recently released.  I didn't notice a difference.

            2. Device monitor detects and loads the right driver for my monitor.

            3. A direct hdmi to hdmi cable had no effect on this issue.  I only changed to dvi because that actually solved other issues, namely the screen not aligned right in POST and allows the monitor to go into sleep.  Other than that, it had no effect on this issue or the other flicker issue where the screen can go completely black for 1-2 seconds (although that is rare).

            4. Any game I play I turn off Vertical Sync.  Should I try turning it on?  I always thought that was needed only for older CRT monitors and not LCD's.  But I could be wrong.

            5. As for as overclocking, who knows, that might play a role, although I don't remember noting a difference when testing it with all overclocks removed.  Neither did the occasional lockups go away (different issue than this) that I get in Crysis (and Crysis 2) or seem to have any effect when I eliminated the overclock.. only to make the game slower. Only thing that seemed to reduce those lockups (from common to rare) was to reduce all the graphics settings to medium.

             

            Anyway, the benefits overclocking gives me, especially overclocking the igpu, far outweigh the minor annoyance this blocking issue gives me.  Next time I reduce the clocks, I'll do a more detailed look to see if that actually effects it any at all (along with playing with vsync).

            • 3. Re: Intel HD 4000 Graphics (i7-3770K) blocking/flicker
              splautz

              I think the Vsync being disabled was to blame for the blocking issue at least in games.  I don't notice it as much, if at all anymore, now with that enabled.   As for as the issue in Windows itself, I couldn't find such an option.  The best I could find was to enable "Application Optimal Mode" under the 3D Advanced Mode within Intel Graphics control panel.  How much that actually improved the fading in issue in Windows, it's hard to say.  It's not always consistent and sometimes looks just fine and sometimes doesn't.