9 Replies Latest reply on Nov 14, 2012 2:09 PM by rikka

    DZ77RE-75K: PS/2 port issues

    rikka

      I have a DZ77RE-75K board that otherwise looks fine, but I cannot get it to detect my keyboards when connected via PS/2. No issues on USB but I do need PS/2 for NKRO (and I think that if the board declares support for PS/2, that support should be in).

       

      The PS/2 port is enabled in BIOS setup, and I'm running the latest BIOS version (dated September 15th).

       

      The keyboard in question is a Filco Majestouch-2 FKBN108M/JB2. Same behaviour with BTC's 6300C.

       

      If connected via PS/2, I cannot get into BIOS setup, and the keyboard's status LEDs blink once after POST finishes. The keyboard does not work in Windows 7 as well, and I don't see the PS/2 port anywhere in the Device Manager.

       

      Any advices?

        • 1. Re: DZ77RE-75K: PS/2 port issues
          splautz

          I use my PS/2 port with a Microsoft keyboard, the one with the split keys, and it works just fine.  My problem is with the black USB ports.  They don't detect my USB mouse whenever going into bios after a Windows restart.   Otherwise the mouse works fine if entering bios any/most other ways.  It's almost as if bios can't get control of the mouse back again after Windows had taken control of it.

          • 2. Re: DZ77RE-75K: PS/2 port issues
            rikka

            I wonder if my board's PS/2 port is dead hardware-wise, then.

             

            (I haven't encountered issues with USB ports like you described; my USB mouse and keyboard are connected to the black-coloured ports as well.)

            • 3. Re: DZ77RE-75K: PS/2 port issues
              splautz

              Interestingly whenever the mouse is frozen in bios, all I have to do is unplug and plug it back in again for the bios to sense it even without doing anything else (either that or CTL-ALT-DEL and then enter bios again).   Maybe it just doesn't like the type of keyboard you are using, and/or maybe all this has something to do with some kind of conflict between the keyboard and the mouse.  who knows.  I'm just glad its easy to get around especially now since I know the conditions under which the issues happen for me.

              • 4. Re: DZ77RE-75K: PS/2 port issues
                rikka

                Well, I just tried 4 different keyboards, no luck — they don't even get initialised.

                • 5. Re: DZ77RE-75K: PS/2 port issues
                  splautz

                  All mine says under device manager is "Standard PS/2 Keyboard" and "HID Keyboard Device", other than that I don't see anywhere else within device manager indicating I even have a PS/2 port.  But it's there and it works.  There could very well be a hardware issue with yours, unless perhaps one of the boot optimization settings within bios is disabling it in some way.  I know I have my optical drive disabled to make it boot faster, but that doesn't make it not work in windows.

                  • 6. Re: DZ77RE-75K: PS/2 port issues
                    rikka

                    Well, I just tried resetting BIOS to its defaults, checking if PS/2 works if I disable it instead of enabling (feel free to laugh), still no luck and I need my NKRO.

                     

                    I guess I'll have to disassemble the PC again and request a replacement from my supplier. Which is a major pain…

                     

                    Thanks for your input.

                    • 7. Re: DZ77RE-75K: PS/2 port issues
                      rikka

                      Update: the board started losing the Marvell controller on the fly (HDDs disappearing from the system along with the controller) and I returned it.

                       

                      Couldn't get a replacement yet, because ALL of DZ77RE-75K available in stores around here come with DZ77BH-55K's I/O shield and drivers CD. Awesome packaging, I daresay.

                      • 8. Re: DZ77RE-75K: PS/2 port issues
                        splautz

                        My mouse is still as frozen as ever in the bios unless I get in by either the back2bio button or hitting ctl-atl-del after the first attempt.   This got even worse after I upgraded to the newest bios version.  It use to work after shutting down and powering it back up.  Now even that doesn't work.   it's either back2bios or the ctl-atl-del technique.   I'm hoping it's simply my settings getting corrupted somehow after bios upgrades.  I did upgrade it immediately to a new version after initially building the computer.   So I'm hoping whenever I can get to popping that battery out, that'll clear it up.  All I can do is hope.  Resetting everything to default in bios or using a different mouse didn't help.

                        • 9. Re: DZ77RE-75K: PS/2 port issues
                          rikka

                          Weird fact: the PS/2 port worked when it was tested in the store.

                           

                          I don't know which CPU did they test it with, but maybe this is related to Sandy vs. Ivy Bridge differences?..