6 Replies Latest reply on Jun 30, 2016 8:13 AM by Amy_Intel

    Intel Rapid Storage Technology 11.6 Broke my RAID-0 - how do I fix it?

    stormfrog

      Ive been waiting for an update of RST for a loooong time to get trim support to my SSD RAID-0. In the beginning it was ridiculously fast but as discs got filled up not so impressing anymore. Then I heard that trim wasnt at all going to work in Windows 7 with raid and that I needed W8... I decided to upgrade from my stock drivers that came with my motherboard (Gigabyte GA-X58A-UD7 rev 2) anyway (RST 10.6).

       

      After update I rebooted my computer. It didnt start, it just frooze on the W7 loading logo. Safemode showed that it frooze when loading classpnp.sys, and when I tried removing that it frooze at disk.sys. Put the files back in original order and ran recovery options to no avail. Nothing worked. I can interact with my raid when I start W7 in recoverymode and open a console but whenever I try to boot OS it just freezes. I have of course also tried to recover to an earlier point but this doesnt work either. Either the restore points are broken or the drivers are not replaced.

       

      So thanks Intel for ruining a completely perfectly running system for me .
      Array: 2 x Intel X25M 120 GB
      Raid configuration:
      SATA mode is set to (XHD). The Extreme Hard Drive (RAID) option is disabled.
      Im using the Intel Raid (obviously), so other Raid options on my board are disabled.
      And SATA AHCI is ofc disabled since I am running SATA in XHD mode because that is the only way to have the Intel Storage Matrix Manager / Rapid Storage Technology create a RAID on the GIGABYTE system. These settings are correct and has been working perfectly for 3 years. Changing the settings in any way will disable my RAID from loading.
      I have absolutely no idea how RST 11.6 so efficiently managed to break my system but I am desperate for help. Ive been googling this problem for the last 5 hours and I have yet to find anyone with the exact same problem.
      The highlights of my setup that makes it unique is probably that I am running two SSD's in RAID-0 and using disks that I suppose could be considered old (they are working fine however w/o broken sectors and whatnot). And that my system is running on said raid, which makes it hard to boot system with the drivers set to currently manage the raid inside of W7.
      Ive been trying to get into my system to be able to purge my system from RST and use the Vanilla W7 drivers instead. But getting into the system seems hopeless. I need to boot system to remove drivers, but to boot system the broken drivers are loaded and boot fails. Catch 22
      I would be very grateful for any and whatever input into this.