1 Reply Latest reply on Oct 31, 2012 4:54 PM by Joseph Oster

    Unable to make vPro Powershell work

      At my company the Windows build team is required to disable some AMT settings such as IDER.  Its my job to audit their work which can be tedious so I would like to write a Powershell script to do the work for me.  I guess my first question is, do I need to use the vPro Powershell module or should I be trying to do this with some other cmdlet that is built-in to Powershell?  So far I have taken the approach that the vPro Powershell module is the way to go but I am open to other suggestions.

       

      Specs: Windows 7 Enterprise SP1

      32bit

      Powershell 2.0

      Intel Management Engine BIOS Extension v6.0.3.0019 / Intel ME v6.0.40.1215

       

      I am launching Powershell as an administrator locally on the machine that I want to access AMT settings.

       

      Import-Module IntelvPro

       

      Write-AmtCredential

       

      ( I'm not exactly sure what password to enter here.  When I boot this HP EliteBook 8440p I have to press CTRL+P to get into MEBx/ME.  At this point I am prompted for a password but not a username.  I made the assumption that Write-AmtCredential wants this password [1]. And I think I read somewhere that a default username of 'admin' will be passed in automatically??)

       

      $AmtPassword = Get-AmtCredential

       

      Get-AMTFirmwareVersion -computername:laptop2 -credential $AmtPassword


      Output:

      ComputerName     Property     Value

      ---------------------     -----------     --------

      blw7027                Error           Cannot Connect

       

      I have also tried

      Get-AMTFirmwareVersion -computername:laptop2

      without the credentials option to see if it would accept my administrator credentials.   Have also tried using -computername with the FQDN.

       

      [1] I verified that I am entering the correct password by booting the laptop and entering into MEBx/ME.

       

      What am I missing?

        • 1. Re: Unable to make vPro Powershell work
          Joseph Oster

          Hey Fred,

          I think Powershell will be just fine to do what you need to do, but it will take a script writing to automate.

           

          When accessing information locally thru Powershell, only limited information is available. By default the module will mount a PSdrive, but it is limited to what it can look at in a local situation. IDER is one of those things it doesn't see as far as I can find. That's where a lot of your issues lay.

           

          If you want to access information locally using Powershell you can do the following, then just navigate like any directory.:

          1. install the Intel vPro module
          2. import-module Intelvpro
          3. cd heci:\

           

          PowerShell will actually work better remotely to access the clients,  Remotely accessing the client will save you from  installing the module on each and every system, as well as allowing full access to vPro settings.

           

          To remotely access a systems firmware version, use the following command line:

                    get-amtfirmwareversion $computername -credential $credential.

           

          As for checking out the IDER setting that will need to be done using PSDrive option:

          New-PSdrive -scope global -name $HostName -psprovider amtsystem -root \ -computername $HostName -credential $AMTCredential

           

          then to access the directory of information use the following command cd <hostname>:\config\redirection

           

          Let me know if you have any further questions

          Joe