4 Replies Latest reply on Nov 6, 2012 12:51 PM by sflesch

    Intel D945PSN Total Memory not correct - common issue

    sflesch

      OK,

      So I figured I'd give this one more go. I see a few other posts with similar issues, but no solutions. I have a D945PSN board with BIOS 108. With 4x1GB sticks installed. The main BIOS screen reports Slot 0, Channels A & B each have 1x2GB sticks. There is no Slot 1 list. Total Memory is 2048. If I go into Memory configuration, it shows all four slots filled with 1GB each, but Total Memory is 2048. To top it all, I have had Windows 7 32 & 64 bit installed and either way, they both report 3,25GB.

      I'm not sure if it's related, but in WMC, Netflix stutters a lot. I also can't run the Windows Experience Index.

      All these symptoms take place in the load that has been on the PC for a while, as well as the fresh loads I did today of 32 & 64 bit Windows 7.

      I realize it's not likely that Intel will fix the bug with a BIOS update, so does anyone have any ideas? I like Intel boards, but if I replace this one, I can't afford an Intel right now

        • 1. Re: Intel D945PSN Total Memory not correct - common issue
          Brad

          Were all 4 DIMMS purchased at the same time as a matched set? I suspect there might be a difference in chip density of one of the pairs of memory sticks with higher density chips a common source of problems and incompatibility.  Also try running CPU-Z from CPUID and look at the memory and SPD tabs for all for modules, they should all be identical or close anyway.

           

          It's not unusual for a 32-bit OS to report less than 4GB installed. My system says "4.00 GB (3.50 GB usable)"  For a 64-bit OS all memory should be usable.

           

          As an idea, looking at the product guide for your motherboard, remove what you say are the recognized DIMMS from Channels A and B slots 0 and put them safely aside. Move modules from Channels A and B slots 1 to slots 0. Restart the system and see if 2 GB is recognized. Just trying to figure out if it's a problem with the motherboard BIOS or your memory modules.

          • 2. Re: Intel D945PSN Total Memory not correct - common issue
            sflesch

            All 4 current DIMMs are the same brand and similar specs. I have tried another set up DIMMS as well with the same results. I can try swapping them around, but the RAM is all within the specs on the Intel site.

             

            Windows 7 32-bit will report the total amount installed, followed by the total amount usable as you said. This just reports the same 3.25GB that 64-bit reports. It doesn't report more as usable.

             

            If you search the forums for D945PSN, you'll find a few other people with this issue. I don't think there's much you can do, as I suspect it's a chipset or BIOS issue. It's a very odd problem. I'm going to try what you suggested as well as grab some more sticks, but I am not very hopeful.

             

            FWIW, Memtest does recognize and pass all four sticks, although I forgot to look if it sees 4GB total.

            • 3. Re: Intel D945PSN Total Memory not correct - common issue
              Hank MkKoy

              Its tuly amazing as I figured I wouldn't find any current posts on this topic. I was literally just about to reinstal windows again as I have th exact same issue!! I only see 3.25 usable memory and my bios only says total memory 2048... I also have 4 1-gigabyte dimms and my windows experience index also will not work. I was truly certain that a reinstall would fix it but after reading your post i'm sure it won't..:(  I am running windows 7 x64 and I'm concerned about other ways this could be affecting my system. If you find a solution please let me know. I wonder if it's because of the video card.

               

              Have you tried downgrading the bios? maybe its a problem with the actual bios 108..

              • 4. Re: Intel D945PSN Total Memory not correct - common issue
                sflesch

                OK,

                So I did some RAM shuffling and look what happens when I have two sticks in Slot 1. Pretty sure this has to be either a really finicky board or it needs a BIOS update which isn't going to happen. I get the same results no matter which RAM is in those two slots. With all four slots populated, the total RAM is only 2048MB even though there are four sticks. All four sticks read on the first screen below, except for the total. On the Second screen, it only shows Channel A & B for slot 0.

                1106021428.jpg1106021428a.jpg

                Sorry if there are any typos...lousy keyboard, I swear!

                 

                P.S. Anyone else's chipset heatsink have issues? I had two of these boards and the plastic piece broke on both.