1 Reply Latest reply on Oct 8, 2012 12:12 AM by Aaron

    will the graphics inside an i7-2630qm use Nvidia cuda/optimus vram for 3D ?

    mofu

      Topic allmost says it all:

       

      Will the Intel HD graphics from the I7-2630qm CPU be using the vram included in onboard Nvidia Cuda/Optimus graphics, for 3D rendering or will it use the system memory to do that?

       

      I am asking as i get a systemcrash when trying any 3D rendering, using either the Intel HD or the Nvidia solution. (CPU stressing all 8 threads with prime 95 shows no overheating).

      I even tried to remove the Nvidia drivers completely, and it still crashed when trying to run anything 3D.

      And of course i tried choosing Nvidia for primary display, and forced choice where possible, resulting in crash as well.

      So now im trying to figure out wether its a matter of bad vram, or if its a cpu problem.

       

      I would allso like to know if the Nvidia Cuda drivers will use the integrated Intel HD for anything when rendering, or if it is working 100% detached from it

        • 1. Re: will the graphics inside an i7-2630qm use Nvidia cuda/optimus vram for 3D ?
          Aaron

          Cuda rendering will only render out to nVidia cards.  With multiple Quaddro / Tesla cards you can actually specify which with the drivers.

           

          OpenCL *might* run on Intel integrated GPUs if they have OpenCL drivers installed and functioning.

           

          Intel integrated graphics will NEVER user RAM on your nVidia card.

           

          If you are getting frequent crashing when trying to render, in addition to making the nVidia card the primary graphics, you should boot into the BIOS and disable the on-board Intel graphics if possible.  You should also check the device manager (assuming Windows) and make sure no Intel graphics are showing up as Display Adapters after disabling in the BIOS.

           

          It might help if you describe what 3D suite you are attempting to render from as well as what settings your are using.  Also, let us know what nVidia graphics card you have.  If by 3D rendering, you mean a game, then you definitely need to have all extra display adapters disabled.  You could be running into a conflict when switching to full screen mode.

           

          Also, go to nVidia's website and update to the latest drivers.  The same holds true for your motherboard and other components.

           

          If this is a laptop, make sure whatever specialized software handles the GPU switching is updated and set correctly for when to switch graphics cards.  Again, if you know you will be using the nVidia card exclusively, disable the Intel integrated HD 3000 from the BIOS during boot up.  You will lose a nice chunk of battery life, but this is the way to go.  Also check with the system vendor support.