3 Replies Latest reply on Oct 3, 2012 6:04 PM by cdelse

    All BIOS updates fail, DG33TL. Tried CMOS reset, now won't post.

    cdelse

      I have recently tried to install a MSI Radeon HD 6670 2GB GDDR3 onto my board. However, after install while it did power on and display the BIOS splash screen, it would lock up at that point. Being able to think of nothing else and receiving no useful suggestions from MSI customer support, I decided to try a BIOS update to see if that might fix the problem.

       

      Problem is, no matter how or which BIOS update I choose to download & install, whether it be the newest one or any inbetween from the revision I currently have. I receive the following:

       

      Current revision: DPP3510J.86A.0326.2008.0227.1102

      Updating revision: DPP3510J.86A.0572.2009.0715.2346

      Preparing image for Intel(R) Management Engine firmware ... [done]

      Preparing image for recovery firmware ... [done]

      Preparing image for main firmware ... [failed!] (30608 bytes overflow)

      Flash update failed!

      Technical information: (0x80000000000000B, 1267)

       

      Depending on the BIOS version I am trying to install, this differs only with (???? bytes overflow). But it literally with EVERY single BIOS version I have downloaded and tried. I have used the .EXE files, I have downloaded Intel Integrator Toolkit and tried it from there, I have downloaded the ISO files as well and booted from CD, and last I have also done a BIOS recovery by removing the BIOS jumper and trying to install via a flash drive with a .BIO file. None of these are successful, and the problem is becoming increasingly frustrating.

       

      However, here is the really weird thing... After trying to install the BIOS via the jumper recovery method, the BIOS update fails as I said. I go to to put the jumper back on, but now the computer boots up with the new video card installed! Fantastic, problem solved I figure. Windows boots up, I download and install the latest drivers from the AMD site, and reboot. Lock up again at the BIOS splash screen. I do the same method to try to boot into Windows again (purposely fail the BIOS recovery update, reboot), and while BIOS posts successfully it now locks up on the Windows splash screen.

       

      It was recommended to me to try to reset CMOS. I took out CMOS battery, left it out a bit, put it back in, and now my display won't even turn on on power up.