4 Replies Latest reply on Jan 22, 2013 10:14 PM by lonertic

    USB 3.0 eXtensible does't play well on MacBook Pro Bootcamp

    jerrey2000

      _Hello forum, I lately bought a MacBook Pro Retina and installed Win 7 on Bootcamp. The "USB 3.0 eXtensible Host Controller Driver" software pack doesn't really work well and gave me some trouble. I have tried downloading the latest "Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver.zip" from the website and still the same.

       

      My chipset info:

      • Intel (R) USB 3.0 eXtensible Host Controller: PCI\VEN_8086&DEV_1E31&SUBSYS_72708086&REV_04
      • Intel (R) USB 3.0 Root Hub: IUSB3\ROOT_HUB30&VID_8086&PID_1E31&REV_0004&SID_72708086

       

      When "USB 3.0 eXtensible" software package is installed by running "Setup.exe": (quite a bunch of drivers and services is installed)

       

      1. VMware Player's USB Arbitration service seems to be messed up and cannot recognize USB device connected, or even if accidentally it does, when connecting VMware will report "USB device is used by others" and refuse to take over the control.
      2. When I hook up Sabrent USB 3.0 HDD Enclosure, model EC-C25P (under the hood, Jmicron Corp. USB Device), the system fails to install the device driver automatically and reported an error.

       

      After uninstalling "USB 3.0 eXtensible", and reinstalling NOT by "Setup.exe", but via devmgmt.msc and "Update Driver Software..." directly from the folder: "Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver\Drivers\Win7", things are a lot better. VMware USB works like a charm and the Jmicron USB HDD Enclosure is recognized properly. However, still some minor issues exist:

       

      1. The "Safe Remove" menu of the Jmicron USB remains grayed out, no way to ensure the OS to eject it.
      2. When the USB 3.0 HDD is connected, from devmgmt.msc, "View Devices by connections", it does not show up as connected via "Intel (R) USB 3.0 eXtensible Host Controller". Instead it hooks up to "Generic USB Hub" and ultimately "Intel (R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26". I'm not sure if that is the correct USB 3.0 connection.
      3. There is no sound of "Device Connect" and "Device Disconnect" any more when I plug/unplug a USB device.

       

      I wonder if anyone has seen the same and any help to address these problems are greatly appreciated.

       

      Thanks.

       

      - Hz