5 Replies Latest reply on Oct 10, 2012 8:37 PM by WanpengQian

    DQ77KB BIOS 0043 GPT Partition Boot Problem

    Joe Turkey

      Hi folks:

       

      I think I've found a bug in BIOS 0043 concerning booting to a GPT partition.  I installed VMWare ESXi 5.0u1 on a DQ77KB motherboard with a i7-3770s processor and BIOS 0043 installed.  By default ESXi 5 creates a GPT boot partition.   After the installation I kept getting an error saying that there was no boot device available.  However, if I hit F10 during the boot sequence and directly picked the hard drive that ESXi was on, then it booted to it just fine.  I tried reinstalling EXSi and played with it quite a bit and it looks like the bug is that the BIOS will not boot to a GPT partition as part of the automatic boot sequence, even if that's the only hard drive installed in the computer and you disable all the other boot locations.  However, if you use F10 to manually pick that same hard drive it will successfully boot to it just that one time.

       

      I ended up reinstalling EXSi 5 and used an override on the install process to force it to create a MBR type partition instead of GPT and after that everything works fine.  Not sure if there is a better place to tell Intel about this problem, but I think they need to put out a BIOS update to fix this.  It's easy enough to recreate; just download ESXi 5 update 1 and let it install by default to a GPT partition on an empty hard drive.

       

      043

        • 1. Re: DQ77KB BIOS 0043 GPT Partition Boot Problem
          blahblahblaaah

          boot problem is notorious with latest Intel motherboard today. I mean Intel brand motherboard. Contact Intel support is your best bet to get your problem solved. If not, send it back for refund. Good luck.

          • 2. Re: DQ77KB BIOS 0043 GPT Partition Boot Problem
            Ryan Engstrom

            Can you explain how you did the override on the install?  I have the exact problem with a CBQ4510H board and ESXi 5.1.0.  Thanks!

            • 3. Re: DQ77KB BIOS 0043 GPT Partition Boot Problem
              Ryan Engstrom

              I actually got my configuration to work with the standard installation.  The change in the BIOS that fixed this issue for me was to configure SATA as AHCI.  I can now boot to ESXi 5.1.0 automatically.  Hope this helps.

              • 4. Re: DQ77KB BIOS 0043 GPT Partition Boot Problem
                Joe Turkey

                When you install ESXi after it loads all the stuff from the CD or USB key, you will see a screen that only lasts a few seconds that says down in the right lower corner to press Shift-O to enter install options.  Do that quickly and then the bottom line of the screen opens.  There is already an option there that has the word "weasel" in it (I kid you not).  Enter a space after that option and then type in:  formatwithmbr  

                 

                That should do it.  Also, if you already have an installation there you must let it repartition everything and you can't tell it to keep your existing datastore, otherwise it won't actually reset the partitions.  If you have VMs in a datastore on the same drive you will have to copy them off before you do this, and then put them back after the reinstall.

                 

                 

                P.S.  If you are using pci passthrough (i.e. the vt-d stuff) with ESXi 5.1, there are lots of problems.  I couldn't get ESXi 5.1 to assign a USB controller to a VM, and I've heard of purple screens of death when starting VMs under ESXi 5.1 that have PCI passthrough devices assigned to them.  I ended up going back to 5.0u1. 

                • 5. Re: DQ77KB BIOS 0043 GPT Partition Boot Problem
                  WanpengQian

                  I have same problem with DQ77MK, I will use your solution later until new bios update available.

                  Thanks.