5 Replies Latest reply on Sep 14, 2012 10:59 AM by sotiris

    Limit exceeded per quad


      I have small setup to test hard drive throughput and to test different drive combinations and i just ran into a small problem that I would appreciate some feedback on!


      The setup is made up of a S3000AH motherboard with a SRCSASLS4I RAID controller without a battery backup unit. The RAID controller is connected to two AXX4DRV3GEXP 4 drive expanders for a total of 8 drives.


      Each expander is connected to one of the RAID controller's 4 output ports. The other two ports on the RAID controller are not connected to anything.


      The expanders have been flashed to the latest version of their software, version 2.14.


      The RAID controller also has been flashed to the latest available version of the BIOS for the SRCSASLS4I, version 1.40.342-1650.


      The Windows drivers are the latest, version even though is not an operating system issue!


      The virtual drive arrays are managed using Intel RAID Web Console 2,  also the latest available version,


      Whatever drive combination of drives is hot-plugged into the 8 slots it is recognized by the Web Console app and virtual disks can be built against them.


      Today I had a combination of 4 SAS 1TB Seagate drives and 4 SATA 2TB hard drives hot-plugged in with the system up and running. The Web Console app recognized them just fine. The mix was of 2 SAS and 2 SATA on each expander.


      Due to a system update the system had to restart and to my surprise got stuck on the RAID controller's boot screen.


      The RAID controller's boot ROM stated that the drive limit per quad had been exceeded and that the configuration was unspported.


      I removed two of the Western Digital 2TB RE4 SATA drives from one of the expanders and rebooted the system and the RAID controller's BIOS allowed the system to boot.


      I have not been able to locate anything that describes this issue and I was wondering if anyone else had come across it.


      I don't understand what exactly the problem is though. The RAID controller supports up to 16 physical drives according to its specifications.


      So what is the issue here? Is it the SAS/SATA mix?


      Any feedback on this would be greatly appreciated!

        • 1. Re: Limit exceeded per quad

          Two general rules:


          1. Do not mix SATA and SAS drives in the same enclosure. In your case, you should plug all SATA in one drive cage and all SAS in the other.


          2. Do not mix SATA and SAS drives in the same array. How did your configure your RAID?

          • 2. Re: Limit exceeded per quad

            RAID arrays are always kept within the same type of drive and are never mixed, not even between model types, much less their interface.


            but re-arranging the drives in each enclosure so all the drives of a certain interface type did not mix with drives with a different interface seems to have solved the problem.


            one interesting observation for me was that moving the drives around from one enclosure to another broke the virtual drives that were already configured. i didn't expect that and if this is the normal behavior i will need to keep it in mind when arranging enclosures. luckily none of the virtual drives had any data.


            is this the expected behavior that a virtual drive breaks when you move the drive from one enclosure to another or from one slot to another within the same enclosure?

            • 3. Re: Limit exceeded per quad

              Moving drives from one slot to another within the same enclosure should be fine... Never tried moving a drive to another enclosure.

              • 4. Re: Limit exceeded per quad



                In my experience, moving drives from one encloser to another - even the exact same hardware - can lead to broken configurations. Although this is not always the case.


                Once you create a VD you should be very careful to keep it in the same encloser and even the same slot that it was initialized in. Some enclosers may be more forgiving than others, but when I am trying to save myself the trouble, I go an extra step.


                Your experience only hardens my oppinion.



                1 of 1 people found this helpful
                • 5. Re: Limit exceeded per quad

                  i have been doing a bunch of test with different type of drives to get an idea of how they behave on this system and i have had some surprises.


                  Western Digital 2TB Caviar Black drives are not recognized by the expander enclosure reliably on startup.


                  i have two of them alone in a 4 drive expander enclosure and they behave the same regardless if they are alone in the enclosure or with other SATA drives.


                  the bevavior is that when these drives are hot-plugged into the cage, they are recognized and can be assigned to new virtual drive and they are stable under stress tests.


                  if the the system is powered down or restarted the controller's boot rom hangs on these drives and declares them as missing. on repeated restarts the quad message that started this thread is shown once in a while.


                  removing these drives from the cage, and restarting allows the system to boot. then hot-plugging in the drives the RWC2 tool recognizes them just fine and allows to import their connfiguration and they are good to go.


                  i have another type of Western Digital 2TB drives, the RE4 line, and these are rock solid without any of the behavior seen with the 2TB Caviar Black models.


                  the RE4 drives' interface is 3Gbit and the Caviar Blacks support 6Bbits but are supposed to be downward compatible. but apparently they don't do it as gracefully as the controller's boot rom would like!


                  also today i took delivery of two brand new Western Digital 600GB Velociraptors and i promptly hot-plugged them in an expander enclosure all by themselves.


                  to my surprise the Raid Web Console 2 tool shows them as bad and refuses to recognizes them. but they play just fine on a traditional SATA port.


                  any suggestions as to what is going on with these drives?