1 Reply Latest reply on Sep 6, 2012 4:52 PM by Victor_Intel

    dh77kc & radeon hd 7970 no video on boot, sometimes

    derrick.allison

      I'm building a new system and have already exchanged the 'DIAMOND AMD RADEON HD 7970 Mfg. Part#: 7970PE53G' for a replacement only to have the same issue. The issue is when I turn the computer on, sometimes there is video and sometimes there is not. So basically the card works sometimes, and sometimes it doesn't. Same issue with both cards, same model. Also, sometimes when there is no video the fan runs at 100% and is very noisy. When there is no video I can connect to the 'integrated video card', open the BIOS, and see that the motherboard doesn't detect the video card even though it is plugged in. When the card does work, I can open the BIOS and see that the card is detected as a PCIe x16 device. So it appears that the card is detected, and sometimes not detected. Other video cards have no problem with this system. PCIe power cables x8 and x6 are securely attached to the video card. I've updated the BIOS from intel.com, reseated the video card, checked connections, and tried different BIOS video options. It seems there is a compatibility issue between the 7970 and the motherboard. Any suggestions to get this card working on every boot?

       

      All hardware is new:

      Intel i7-3770 (3rd generation ivy core)

      Intel motherboard dh77kc

      DIAMOND AMD RADEON HD 797

      CORSAIR XMS 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model CMX8GX3M2A1600C9

      650w OCZ modular power supply

        • 1. Re: dh77kc & radeon hd 7970 no video on boot, sometimes
          Victor_Intel

          Hello Derrick,


          I understand that you are experiencing problems with the proper recognition of your video card on the Intel(R) Desktop Board DH77KC.

           

          This seems to be one of those unfortunate cases where the video card is not properly recognized during POST and it is  usually confirmed to be a compatibility problem.

           

          From our side I recommend you to go in to the boot tab and enable the expansion card text option to see if it will help you. Unfortunately there are no other changes that can be made to make your video card work with this system.

           

          Regards.

           

          PV