14 Replies Latest reply on Sep 27, 2012 4:42 PM by cdelse

    DG33TL refuses / fails all BIOS updates


      I have recently tried to install a MSI Radeon HD 6670 2GB GDDR3 onto my board. However, after install while it did power on and display the BIOS splash screen, it would lock up at that point. Being able to think of nothing else and receiving no useful suggestions from MSI customer support, I decided to try a BIOS update to see if that might fix the problem.


      Problem is, no matter how or which BIOS update I choose to download & install, whether it be the newest one or any inbetween from the revision I currently have. I receive the following:


      Current revision:     DPP3510J.86A.0326.2008.0227.1102

      Updating revision:     DPP3510J.86A.0572.2009.0715.2346


      Preparing image for Intel(R) Management Engine firmware ... [done]

      Preparing image for recovery firmware ... [done]

      Preparing image for main firmware ... [failed!] (30608 bytes overflow)


      Flash update failed!


      Technical information: (0x80000000000000B, 1267)


      Depending on the BIOS version I am trying to install, this differs only with (???? bytes overflow). But it literally with EVERY single BIOS version I have downloaded and tried. I have used the .EXE files, I have downloaded Intel Integrator Toolkit and tried it from there, and I have downloaded the ISO files as well and booted from CD. None of these are successful, and the problem is becoming increasingly frustrating.


      Any help is appreciated. Thanks in advance.