5 Replies Latest reply on Sep 7, 2012 1:56 AM by Jon

    DH77KC will not go past splash screen after Adaptec BIOS loads

    Jon

      Hi All,

       

      I have an Intel DH77KC running the latest BIOS (095). The system was able to boot using a SATA drive attached to the onboard controller. When I add in an Adaptec 5805 (PCIe x8) into the x16 PCIe slot the system boots process is as follows:

      - show the Adaptec BIOS

      - allows me to control-A to configure

      - shows the attached drives and logical volumes

      - gives the message the the BIOS was successfully loaded

      - shows the Intel splash screen with F2/F7/F10 options and just sits there.

       

      The keyboard is active as far as caps lock on/off, but if I select one of the F options the system appears to hang. I have left the splash screen on for 10mins without anything changing. Restarting the machine as this stage tells me that the "BIOS has detected unsuccessful POST attempts" but I cannot get into BIOS or boot successfully regardless of which option I chose.

       

      The only way to get back into the BIOS is to remove the RAID card. I have attempted the following with no results or variation to the above symptoms.

      - enable and disabled UEFI boot

      - removed all other devices

      - disabled unused onboard devices

      - enabled and disabled power settings on PCIe

      - set the default video device to the onboard to ensure no conflicts with the x16 slot.

       

      The RAID card is a Sun badged Adaptec and is running the latest BIOS/firmware (provided by Intel) and was running fine in the previous Intel DQ45CB motherboard in a x16 PCIe slot

       

      From searching these forums there seems to have been an number of people that had issues with RAID cards in x16 PCIe slots. The technical documentation for the DH77KC does not specify the x16 slot must only contain a graphics card so I would expect this RAID card to work as it has on my previous Intel motherboard. It seems the RAID card does actually work, the BIOS loads and I can configure the arrays as expect. The system just does not proceed after that.

       

      Is there something I'm missing here?

       

      Regards,

       

      Jon

        • 1. Re: DH77KC will not go past splash screen after Adaptec BIOS loads
          Victor_Intel

          Hello Jon,


          I understand that you are experiencing problems using a RAID controller card on the Intel(R) Desktop Board

          DH77KC with the latest BIOS.

           

          The Intel(R) Desktop Boards will usually not support RAID controller cards as there might be conflicts. The PCI Express* 16X is intended to be used with video cards but not limited to them. The fact that the card initializes means that the motherboard and card are working.

           

          At this point you should try a rollback to a previous BIOS.

           

          Regards.

           

          PV

          • 2. Re: DH77KC will not go past splash screen after Adaptec BIOS loads
            Adaptec Support

            Jon,

             

            Try disabling the Adaptec runtime BIOS in the ctrl+A controller config and see if that lets you boot. You won't be able to boot from the controller with the runtime BIOS disabled, but you should be able to see the arrays you've configured as logical volumes in your OS once it boots.

             

            Please open a case directly with Adaptec Support by going to http://ask.adaptec.com and clicking on the "Ask a question" link on the right-hand side of the page.

             

            Regards,

             

            Adaptec by PMC Technical Support

            • 3. Re: DH77KC will not go past splash screen after Adaptec BIOS loads
              Jon

              Many thanks for both of your replies. I will try the runtime BIOS disable first and if that proves unsucessful I will roll back to the original motherboard BIOS. I will report back within a few days.

               

              Thanks again.

               

              Jon

              • 4. Re: DH77KC will not go past splash screen after Adaptec BIOS loads
                Hugo

                I'm having the same issue as the topic starter. Same motherboard and bios version, but in my case with an Areca 1220 controller in place in the pci-e x16 slot. The previous bios works fine.

                This controller does not has the option to disable it's bios, so I am unable to test that option.

                I will now revert to the older bios, but it would be very nice to see the issue fixed. I know this board is just a desktop board, but this is just my home server, so no need for expensive server boards.

                I'm willing to test beta bios releases if that may help resolving this issue.

                 

                Thanks in advance.

                • 5. Re: DH77KC will not go past splash screen after Adaptec BIOS loads
                  Jon

                  Sorry for the late follow up on this post. I tested both Adaptec Support's and Victor_Intel's suggestions.

                   

                  Disabling the runtime BIOS on the RAID card did allow the system to start to boot into the OS, however the OS loading stopped at the RAID card driver. This was booting into ESXi 5 and it hung on aacraid. This same install of ESXi 5 starts without issue with this RAID card on my previous Intel motherboard.

                   

                  Rolling back the BIOS to the first release (069) allowed me to starting to boot the OS as well but still hung on aacraid. I have tried the latest provided aacraid driver on both Intel BIOS with no difference. On the first release Intel BIOS I was able to start booting OS with either the Adaptec runtime BIOS enabled or disabled.

                   

                  I have since tried an IBM M5014 (LSI9260-8i) and that boots to ESXi and is all accessible on both old and new BIOS.

                   

                  I am in the same boat as Hugo in that this is my home server but still expected to be able to run the same PCIe RAID card as I did on my previous Intel board without issue.

                   

                  Regards,

                   

                  Jon