4 Replies Latest reply on May 23, 2014 11:15 AM by allan_intel

    D915PSY BIOS recovery


      Hello, I have a friend's computer with motherboard D915PSY. After the unsuccessful BIOS flashing (from Windows) it doesn't work anymore.

      I tried BIOS recovery according to the manual in Read Me (under the downloads here: Download Center), but it didn't work. I placed "CY0040P.BIO" file on the floppy disk, removed the BIOS Configuration Jumper, started the computer and the following occured...

      1) Computer started to load something from the floppy drive

      2) Single beep came out

      3) Two beeps came out

      4) Multiple beeps came out (about 4-5)

      5) Computer turned off


      After turning off I tried to replace the BIOS Configuration Jumper and start the computer again, but nothing changed.

      Is anybody here able to tell me what am I doing wrong or where is the problem? Any help would be appreciated.

      Thank you very much

        • 1. Re: D915PSY BIOS recovery



          We would like to inform that this motherboard is end of interactive support (EOIS) meaning the board is not longer supported or manufactured. As an additional detail, we recommend clearing the CMOS battery for 30 minutes and try the BIOS recovery update again. If the issue persists we recommend replacing this motherboard with a different one.

          • 2. Re: D915PSY BIOS recovery

            It's solved. I tried to recover it using older BIOS version and it worked But thank you for your response

            • 3. Re: D915PSY BIOS recovery

              I have a similar experience... I tried to flash D915PSY BIOS with 0040 and it didn't start again. So i tried recovery and just the oldest 0010 version worked (I had to find some really old notebook with floppy drive to prepare it).

              But then I made a fatal error when I decided to update it step by step to determine the newset version working. I got to 0021, which haven't boot again and since then I am unable to recover it with 0010?!

              I am angry and really disappointed Why the hell the same diskette doesn't work again? There are the same circumstances.


              Anyways the recommendation for the others: If you have D915PSY don't ever try to flash it. Flashing from Windows will proceed without a problem, but then it tells you to you reboot and you might never get it working again


              //EDIT: Damn it! Obviously I am answering to my own post So it means I have the same board in my hands and the same problem is here again


              //EDIT2: I give up. I finally made it working again with version 0010 (beep code was still wrong, but I tried normal run afterwards and it worked). Then I flashed that to 0014 and can't go further because the later versions causes the unbootable state despite the fact that it writes "Flashing/Reprogramming was successfully completed". It seems like we have a different view on the "successful" state

              • 4. Re: D915PSY BIOS recovery

                Thanks for joining the community and sharing the post.