2 Replies Latest reply on Aug 15, 2012 7:03 PM by RobD

    DX79SR odd bios boot order - advanced v. normal


      Have just noticed that when changing the hdd boot order in advanced view, that the change is not carried over to normal view ??

      The reverse is also true, what you do in normal view is not carried over to advanced view.

      I guess bios boots what ever order is set in which ever view is selected?? or does it???

      Somewhat unexpected behavior. Was it intentional that Intel arranged it like this?

      If yes, why? If no, is it a bug that could cause issues in certain hdd and/or efi arrangements? [yes, I'm talking to you "hang at E7"!!]


      Here's what led me to this and got me wondering about the boot arrangements and drive detection in this bios.

      I've had major drama's with hangs at E7/F8, right as the starting windows splash appears or sometimes a bit before that. It's even happened booting the win dvd!

      The culprit appeared to be my Logitech DiNovo wireless usb dongle, when it was plugged into a rear usb2 port,.If I moved it to a front usb port [via onboard header] the problem went away.


      Another issue that now appears to be playing into this is the 100% repeatable hang at 5A when a usb2 hdd [sata or ide] is plugged into a rear usb port.

      But again the Logitech wireless usb dongle is also involved. The hang only happens if a usb hdd and the Logitech dongle are both plugged into rear usb ports.

      But there's yet another caveat, if you plug in a 2nd usb hdd into another rear port, the hang does not occur - ah-ha, the plot starts to thicken a little.

      It's almost as though the wireless dongle is being assigned a 'phantom' drive slot in bios and confuses bios when a usb hdd is also present, but as soon as you plug in more than one usb hdd, or even a multi card flash reader, the usb dongle gets 'kicked out' and can't cause trouble anymore.


      So, this brings us to the present day.

      I've since installed the latest bios 0527 and downloaded the newer F6 rst drivers to see if any of my issues went away.

      I set up a 4tb raid0 array on the intel controller and did a full install of 7x64 with all drivers = numerous restarts + extra restarts to check progress and did not have a single hang, with the wireless dongle in a rear usb port - great, looks promising on that front.


      I then plugged up a single 500gb drive to the marvell controller to see if there was some way I could get dual boot working between a efi/gpt volume and a mbr volume.

      Right away at the first restart of installing x64 to the hdd on the marvell, I had a hang and at almost every restart after that.....hmmmm.....what the hell is going on here!!


      That's when I went into bios to check on other boot options in persuit of dual boot and discovered the weird boot order in advanced versus normal view, which got me wondering if this and the hang issues are all tied together somehow.


      However, it may be that the E7 hang is when install/boot is on marvell and wireless dongle is in a rear usb port.

      It did seem though, that once I set normal and advanced views to the same boot order, the E7 hang went away, but - I then put it back how it was and still couldn't get it to hang, but - maybe it's when bios itself configures a new boot order on the 1st restart of installing windows [puts hdd ahead of dvd] that the trouble begins. 

      Maybe the hang would happen on the intel controller as well, if uefi is disabled....don't think I've tried that yet??

        • 1. Re: DX79SR odd bios boot order - advanced v. normal

          Hello RobD,

          We appreciate you feedback and findings, I will send this information to the department in charge of handling the BIOS bugs.  I have noticed that sometimes when hard drives are installed on the marvel* controller, the boot order may not work properly.

          Hopefully the errors reported here will be fixed on a near future BIOS release.



          • 2. Re: DX79SR odd bios boot order - advanced v. normal

            Hi PV,

            Thanks for following up on this! 

            I also have an update for the hang at E7, it always ocurrs the very moment that 'E7' appears on the monitor down in the right lower corner, and with a ssd [intel 520 240gb] as the boot drive the hang happens at almost every restart, but only on restarts. It never hangs after pressing reset.

            So bad is the problem when a ssd is the boot drive, that even using a front usb2 port for the wireless dongle no longer helps.


            With regard the hang at 5A problem, I have tried a usb pen drive with the wireless dongle and when both are in rear usb2 ports, that combination also persistently hangs every time..

            But so far, it only happens with the Logitech DiNovo wireless dongle.


            I am hoping that finding the reason for any one of these three, will fix all three problems.