5 Replies Latest reply on Aug 10, 2012 12:45 PM by COLOMBEL

    Hyper-V VM do not communicate on VLAN network- Intel 82574L

    COLOMBEL

      Hi,

       

      We have 2 dedicated server on HyperV R2 Core server environment.

       

      There are connected together by a VLAN (ID 2894). The 2 Hyper-V host communicate normally in the VLAN network but, in one of your Hyper-V host, no Virtual machine is capable to use the VLAN Network. no ping response to gateway or to other host in VLAN network, except with their Hyper-V parent.

       

      The 2 hosts are the same Intel network card : Intel 82574L with the same driver (17.1)

       

      Procedure Used :

      - Install Intel Driver 17.1 on Hyper-V Host with ASN (Download Center)

       

      - Reboot

       

      - Create VLAN with script :

      "C:\Program Files\Intel\DMIX\CL\PROSetCL.exe" Adapter_createvlan 1 2894 vrack2894

      ping -n 5 127.0.0.1 >NUL 2>&1

      "C:\Program Files\Intel\DMIX\CL\PROSetCL.exe" Adapter_createvlan 10 vrack0

      ping -n 5 127.0.0.1 >NUL 2>&1

       

      - Reboot

       

      - Unbind all Protocol on VLAN 2894 network Card with nvsbind (follow Intel� Server Adapters — Hyper-V* virtual NIC will not communicate)

        >nvspbind -d {VLAN2894 NETWORK CARD GUID}


      - Reboot


      - Create Hyper-V External Virtual Switch (Shared with Operationg System and VLAN Tagging 2894)


      - Reboot


      - Rebind all Protocol on VLAN 2894 network Card with nvsbind : (follow Intel� Server Adapters — Hyper-V* virtual NIC will not communicate)

      >nvspbind -e {VLAN2894 NETWORK CARD GUID}


      - Reboot


      - Add VLAN virtual Network to Virtual Machine and start it


      -  Configure IP Address with VLAN network (172.16.0.50 mask 255.240.0.0, gateway 172.16.31.255.254)


      - Test to Ping a VM in the second hyper-v Host with the VLAN Network (172.16.0.1 mask 255.240.0.0, gateway 172.31.255.254)


      - No ping respond, host is uncreachable


      Why ??

      In Addition, if we setup an IP Address on VLAN network in this Hyper-V Host, that's work, it ping the 2nd hyper-V host and all VM. it's only when the network traffic throught the hyper-v virtual switch.


      The same procedure in the second Hyper-v Host work correctly (without unbind protocol, vlan network works directly)


      We are trying to reinstall completly the Hyper-V host many times


      We lease these two servers in a hosting

       

      Any Ideas on any of these problems?


      Thanks

      Charles.

        • 1. Re: Hyper-V VM do not communicate on VLAN network- Intel 82574L
          COLOMBEL

          In addition, there are strange things in the protocols on the server where it does not work :

           

          Hyper-V Protocol (Server 1 - VLAN Network not ok)

           

          {80D263AD-14D2-4E93-BD38-4F323860DF53}

          "vms_mp"

          "Microsoft Virtual Network Switch Adapter"

          "Local Area Connection 2":

             disabled: ms_netbios       (NetBIOS Interface)

             enabled:  ms_netbios       (NetBIOS Interface)

             disabled: ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_pacer         (QoS Packet Scheduler)

             disabled: ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_tcpip         (Internet Protocol Version 4 (TCP/IPv4))

             enabled:  ms_tcpip6        (Internet Protocol Version 6 (TCP/IPv6))

             enabled:  ms_rspndr        (Link-Layer Topology Discovery Responder)

             enabled:  ms_lltdio        (Link-Layer Topology Discovery Mapper I/O Driver)

             disabled: vms_pp           (Microsoft Virtual Network Switch Protocol)

             disabled: ms_netbt         (WINS Client(TCP/IP) Protocol)

             enabled:  ms_netbt         (WINS Client(TCP/IP) Protocol)

             disabled: ms_smb           (Microsoft NetbiosSmb)

             enabled:  ms_smb           (Microsoft NetbiosSmb)

             disabled: iansprotocol     (Intel(R) Advanced Network Services Protocol)

           

          {46D287B5-8F47-4C8C-85A6-892946A72120}

          "vms_mp"

          "vlan"

          "Local Area Connection 7":

             disabled: ms_netbios       (NetBIOS Interface)

             enabled:  ms_netbios       (NetBIOS Interface)

             disabled: ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_pacer         (QoS Packet Scheduler)

             disabled: ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_tcpip         (Internet Protocol Version 4 (TCP/IPv4))

             enabled:  ms_tcpip6        (Internet Protocol Version 6 (TCP/IPv6))

             enabled:  ms_rspndr        (Link-Layer Topology Discovery Responder)

             enabled:  ms_lltdio        (Link-Layer Topology Discovery Mapper I/O Driver)

             disabled: vms_pp           (Microsoft Virtual Network Switch Protocol)

             disabled: ms_netbt         (WINS Client(TCP/IP) Protocol)

             enabled:  ms_netbt         (WINS Client(TCP/IP) Protocol)

             disabled: ms_smb           (Microsoft NetbiosSmb)

             enabled:  ms_smb           (Microsoft NetbiosSmb)

             disabled: iansprotocol     (Intel(R) Advanced Network Services Protocol)

           

          Hyper-V Protocol (Server 2 - VLAN Network OK)


          {80D263AD-14D2-4E93-BD38-4F323860DF53}

          "vms_mp"

          "Microsoft Virtual Network Switch Adapter"

          "Local Area Connection 2":

             disabled: ms_netbios       (NetBIOS Interface)

             disabled: ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_pacer         (QoS Packet Scheduler)

             disabled: ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_tcpip         (Internet Protocol Version 4 (TCP/IPv4))

             enabled:  ms_tcpip6        (Internet Protocol Version 6 (TCP/IPv6))

             enabled:  ms_rspndr        (Link-Layer Topology Discovery Responder)

             enabled:  ms_lltdio        (Link-Layer Topology Discovery Mapper I/O Driver)

             disabled: vms_pp           (Microsoft Virtual Network Switch Protocol)

             disabled: ms_netbt         (WINS Client(TCP/IP) Protocol)

             disabled: ms_smb           (Microsoft NetbiosSmb)

             disabled: iansprotocol     (Intel(R) Advanced Network Services Protocol)

           

          {B185D29D-858E-46A2-B9EC-C82617089111}

          "vms_mp"

          "Vlan"

          "Local Area Connection 9":

             disabled: ms_netbios       (NetBIOS Interface)

             disabled: ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_server        (File and Printer Sharing for Microsoft Networks)

             enabled:  ms_pacer         (QoS Packet Scheduler)

             disabled: ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_msclient      (Client for Microsoft Networks)

             enabled:  ms_tcpip         (Internet Protocol Version 4 (TCP/IPv4))

             enabled:  ms_tcpip6        (Internet Protocol Version 6 (TCP/IPv6))

             enabled:  ms_rspndr        (Link-Layer Topology Discovery Responder)

             enabled:  ms_lltdio        (Link-Layer Topology Discovery Mapper I/O Driver)

             disabled: vms_pp           (Microsoft Virtual Network Switch Protocol)

            disabled: ms_netbt         (WINS Client(TCP/IP) Protocol)

            disabled: ms_smb           (Microsoft NetbiosSmb)

             disabled: iansprotocol     (Intel(R) Advanced Network Services Protocol)

          • 2. Re: Hyper-V VM do not communicate on VLAN network- Intel 82574L
            Patrick_Kutch

            Hi,

             

            thanx for bringing your issue to us.  We will see if we can reproduce your issue and post back here with our findings.

             

            Stay tuned!

             

            - Patrick

            • 3. Re: Hyper-V VM do not communicate on VLAN network- Intel 82574L
              COLOMBEL

              Hi Patrick,

               

              thanks you very much for your reponse.

               

              it would seem that we found the cause of the problem

               

              Our hoster proposed a solution to map a Public IP Address to a VM with a MAC Adress filter. And when you delete the virtual mac address created before the vlan creation, vm succesfull connect to the vlan network.

               

              Charles.

              • 4. Re: Hyper-V VM do not communicate on VLAN network- Intel 82574L
                Patrick_Kutch

                I am glad you are up and running.

                 

                The much-smarter-then-me guys I work with looked at your problem last night and believe that it was likely a simple configuration step that was over looked.

                 

                They believe that you likely may not have setup the VM to have VLAN tagging enabled in the VM settings.  If you go to the settings for you VM, then select Network Adapter, there is an 'Enable virtual LAN identification' checkbox in the middle of the page.

                 

                There are 2 types of VLANS that can be set.  One for the vSwitch, in which the VLAN tag is for the shared interface to the host, and a VM VLAN tag used for VM communications.  These are exclusive to each to other and do not interfere with each other.  For a VM to be able to communicate on a tagged VLAN, the tag must be set in the VM settings window.

                 

                Hope that helps.

                 

                Happy Virtualizaing!

                 

                - Patrick

                 

                 

                • 5. Re: Hyper-V VM do not communicate on VLAN network- Intel 82574L
                  COLOMBEL

                  Hi Patrick,

                   

                  We have setup the VM to have the VLAN Tagging enabled, both on the Swith and on the VM network adapter all the test time.

                   

                  In fact, we have done nothing in our VM and host configuration for this to work correctly. the only thing is to disable a hoster features who allows VM to have an Public IP. But this does not work quite yet because we have with our hosting fees at three public IP addresses for our VMS, and we blocked this option to use only three vms on our private network VLAN. We have opened an incident at our hoster.We are awaiting its response because we don't understand why this feature block our VLAN network.

                   

                  Again thanks for your help and our answer.

                  Charles