10 Replies Latest reply on Sep 7, 2012 1:31 PM by yoshi2889

    Intel Centrino Advanced-N 6230 connection drops

    yoshi2889

      Hello,

       

      I recently bought the Intel Centrino 6230 adapter as a replacement for my Atheros 9285. It works awesome!

       

      Although I have a pretty big problem. The adapter seems to drop the wireless connection when it has downloaded a file with rapid speed.

      When it downloads a file of, lets say, 500 MBs with a speed of 12 MB/s (not Mbit), the connection drops. 11 MB/s, 9, MB/s, 5 MB/s all down per second until it goes to 100 Bytes/s. It also happens with a speed of 3 MB/s.

       

      My laptop is an ASUS K53E, with a Core i5 2450M running on the Intel HD Graphics 3000 and 8 GB of RAM, soon to be getting an upgrade to an SSD. The laptop is running Windows 7, but the same thing happens in Ubuntu Linux 12.04.

       

      EDIT: I failed to mention that I'm connected to either 5 GHz or 2.4 GHz on an ASUS RT-N66U router with 300 Mbit/s. My iPod touch and HTC HD2 connect just fine to that same router (although on 2.4 GHz)

       

      What could be the problem, and how am I able to fix this?

      Thanks a lot!

        • 1. Re: Intel Centrino Advanced-N 6230 connection drops
          Stitchz@Intel

          Hello yoshi2889,

           

          If the behavior is seen on both Windows* and Linux* Operating Systems, this leads to believe there's an integration problem with the Intel® Centrino® Advanced-N 6230 and the laptop.

           

          Note that the Intel® Centrino® Advanced-N 6230 adapter is meant to be professionally installed by Original Equipment Manufacturer (OEM) technicians on certified systems only.

           

          In this case what we recommend and encourage you to first contact the Original Equipment Manufacturer (OEM) to determine if the product is approved for use in your computer.

           

          Your system must be compliant with the required FCC certifications in compliance with the International Special Committee for Radio Interference standards for radiated and conducted electromagnetic interference.

           

          Installing an aftermarket wireless adapter in your laptop can cause several issues which may affect usage of the wireless adapter or laptop. Some of these issues may include the following:

           

          - The OEM may have installed the wireless adapter with a lock to prevent installation of another adapter.

          - Your adapter may not be electrically compatible with your laptop that may cause the adapter and/or your laptop to no longer function.

          - Wireless hardware installation and use is subject to regulatory approval, and the adapter purchased may not support your local regulations.

           

          For additional information, refer to:

          Intel® WiFi Products - Upgrade or exchange Intel® wireless adapter hardware

          http://www.intel.com/support/wireless/wlan/sb/CS-006006

           

          Intel® WiFi Products - Why doesn't my laptop recognize my new Intel wireless adapter?

          http://www.intel.com/support/wireless/wlan/sb/CS-031167.htm

           

          Cheers!

          1 of 1 people found this helpful
          • 2. Re: Intel Centrino Advanced-N 6230 connection drops
            yoshi2889

            Thank you for your reply.

             

            I just read over my post and I accidentally mentioned the 6230 adapter -- I mean the 6235 adapter

             

            I don't think ASUS put a lock on the Atheros adapter. The Intel adapter works fine -- Just drops every so often.

            Same for electric incompatibility -- The adapter works fine, so far, with connection drops.

            I asked ASUS about this adapter and they told me it should work.

             

            I just reinstalled the drivers, as the My WiFi technology didn't recognize my adapter either and I didn't feel like fixing that as I have to reinstall Windows in a few days (upgrading to SSD). See how this goes.

            • 3. Re: Intel Centrino Advanced-N 6230 connection drops
              steve06

              Dear yoshi2889 and Intel support team,

               

              I have the same issues as yoshi2889 with my brand new Intel Centrino 6235 Wifi adapter!

               

              My system is a brandnew desktop computer with an Intel i7 CPU, an Intel Z77 chipset, an Asrock Z77E-ITX mainboard and Windows 7 64-bit.

               

              Previously, I already encountered the issue with this adapter's predecessor, the Intel Centrino 6230 and only managed to resolve it by going back to an older driver version. If my memory is correct, the Intel Proset 14.x version range worked flawlessly, but the 15.x drivers lead to the dropouts (I always use 64-bit drivers).

               

              These could occur randomly after 5 or after 50 minutes. The adapter wouldn't reconnect to the wireless network unless it was reset. The wireless router itself is fine as there are over a dozen devices from all types of brands that connect regularly to it without any problem at all.

               

              On the 6235, going back to a 14.x driver does not seem to be an option on the table, because the device seems to be only supported by 15.x versions. I already tried going back from the recent 15.2 version to the previous 15.1.1 (after uninstalling through the device manager), but the problem still persists. Now I just went back to 15.1.0 and it's been ok so far, but i'm not very optimistic.

               

              @Intel: There's clearly a driver problem here that needs to be adressed! Your reply to yoshi's original post above is just generic and seems like you wanted to dodge and ignore the issue.

               

              I've been assembling computers for over a decade and believe me, the re IS a problem, and it does NOT stem from outdated hardware as for instance in my case I used the most recent components.

               

              Best regards,

              Steve

              1 of 1 people found this helpful
              • 4. Re: Intel Centrino Advanced-N 6230 connection drops
                yoshi2889

                Thank you for replying!

                 

                Glad to know that I'm not the only one having this issue.

                 

                I fixed a great deal of the drops by removing the ProSet and wireless software and installing just the wireless driver.

                 

                When close to the router almost no drops happen, when I go further away (like 10 metres away?) the drops happen more frequently -- No other device in our home has any trouble with that distance.

                 

                Hope this is of any info to Intel.

                • 5. Re: Intel Centrino Advanced-N 6230 connection drops
                  steve06

                  Thanks for the feedback, yoshi.

                   

                  I do not use the dashboard either, just the driver and I let Windows manage the Wifi connections. Still, the problem appears 3-5 times a day, which is VERY annoying.

                   

                  Hope Intel people join the discussion and try to help actively.

                  • 6. Re: Intel Centrino Advanced-N 6230 connection drops
                    steve06

                    @Yoshi:

                    I appear to make progress by disabling the "802.11n Mode" in the adapter properties under the Advanced tab, though I do not have sufficient evidence to confirm this successfully eliminates the problem.

                     

                    Could you please also check how that works for you?

                     

                    Of course, it's frustrating to have to disable N if this is what you bought the adapter for. But maybe this could guide Intel in the search for a bugfix.

                    • 7. Re: Intel Centrino Advanced-N 6230 connection drops
                      yoshi2889

                      Hey steve06,

                       

                      Seems to fix it for a bit, but then my internet is damn slow

                       

                      I hope Intel can fix this soon enough.

                      • 8. Re: Intel Centrino Advanced-N 6230 connection drops
                        steve06

                        thanks, if it doesn't bother you too much, let's just keep n-mode off for a couple of days just to confirm that this is a work-around to a problem that yet needs to be adressed.

                        • 9. Re: Intel Centrino Advanced-N 6230 connection drops
                          yoshi2889

                          Hey steve06,

                           

                          I'm sorry but I can't have my adapter set to just 54 Mbit/s, I need to have full-speed internet to be available at all times

                           

                          However if there's a diagnostic tool or something that I can run, I'll be more than glad to run it.

                           

                          As a side-note, the Intel Driver Update Utility on the Intel site (obvious ftw) doesn't detect the Bluetooth drivers.

                          • 10. Re: Intel Centrino Advanced-N 6230 connection drops
                            yoshi2889

                            Okay, so I upgraded the firmware of the router -- All seems to be good on 5 GHz now.

                             

                            There was a newer firmware available at ASUS' site. Installed that through the routers' upgrade panel (manual upload), now everything works like a charm so far. I can download at full speed from a distance and no drops happen anymore.

                             

                            I got to checking for a firmware upgrade since my iMac (2011 21.5" model) was also having the same kind of drops, which indicates that there must be a problem somewhere else.

                             

                            steve006: Probably this won't be of any help to you. I suggest contacting the manufacturer of your router to see if they have any tips how to fix it.

                             

                            Thank you all for replying and checking this out, this is fixed for me