1 Reply Latest reply on Aug 10, 2012 9:01 AM by Luis_Intel

    New i5 3570k refuse to work with my asus 7850 card

    Andrew

      Hello, Im having a big issue after yesterdays upgrade, I was running a Sandy Bridge Pentium g620 with Intel DH77EB M/B and Asus 7850 Graphics, Corsair Builder 430w v2. I decided to order a I5 3570k the other day and yesterday that i picked it up after installing the cpu the 7850 doesnt seem to be recognised at all in bios.

       

      I tried flash every single of the 4 bios available from intel in the m/b, clear cmos, disabling i5's 4000 HD graphics with no result. Its like the card doesnt exist at all.

       

      My First though was that there is something wrong with my card (card fan is working when booting). I replaced the cpu with my older one and card worked as intended.

       

      Now my concern is that there is something wrong with the cpu. The cpu is working fine except from the issue with the card. Temperatures on idle are 40-45c. IntelBurnTest v2.54 runned with no error and temps topped 80-85c on full load.

       

      I think there are 3 things that might be wrong,

       

      1) 3570k have a bad pci-e 16x 3.0 bus. Dont know if its even possible but with g620 the graphics card is working in pci-e x16 2.0.

      2) 7850 cant switch to pci-e 3.0. Doesnt seem possible too.

      3) H77 chipset doesnt support pci-e 16x with k proccessors or m/b is failing.

       

      or im missing something else?

       

      Note that ofcourse there is no overclock in cpu or graphics card.

       

      Any advise or idea is welcome.

        • 1. Re: New i5 3570k refuse to work with my asus 7850 card
          Luis_Intel

          Checking the specifications for the processors (http://ark.intel.com/compare/53480,65520) the PCI Express* revision of the Pentium processor is 2.0 and for the i5 is 3.0. Since your motherboard is revision 2.0 using the Pentium processor your video card is downclocked and it works at 2.0 with no issues. Then, having installed the i5 processor as we know it works at 3.0 and the video card until that point can work at 3.0 also. The problem is that the PCI Express* bus of the motherboard doesn’t support 3.0. If you have the possibility, test another motherboard that be PCI Express* 3.0 compliant with the processor and video card and see if the issue persists.