7 Replies Latest reply on Sep 20, 2012 6:25 AM by londonsteve

    DZ68DB Memory Error

    josh

      hi,

       

      i'm trying to setup a new system with a DZ68DB and i7-3770.

      although i used recommended modules (listed at Intel� Desktop Board DZ68DB — System memory) the startup failed with memory error (3-beeps). tried out 3 different suppliers and every dimm socket, without any success.

       

      the modules and cpu are working fine at another system, so i am at a loss.

       

      same problem with a 2nd DZ68DB board.

       

      maybe a bios update would help, but how can this be done as i don't even come into the bios setup ???

       

      thanks for your help and have a good day

       

      joshua

        • 1. Re: DZ68DB Memory Error
          londonsteve

          See http://download.intel.com/support/motherboards/desktop/sb/6series_update_flowchart10.pdf

           

          Check the AA number on your board. If the number at the end is less than AAG27985-105 then the board will not have been produced with a high enough BIOS version for 3rd gen processors.

           

          You will need a Sandy bridge processor (I used a cheap celeron) to do the necessary updates.

           

          Caution.... Read the flow chart carefully - do not rush or skimp - read how to do F7 and recovery flashes - again be VERY careful not to deviate from those documented processes.

           

          Good luck - flashing these boards is very dangerous even when done correctly. I have had terrible issues with i7-3770 and DZ68BC.

          • 2. Re: DZ68DB Memory Error
            josh

            hi steve_uk,

             

            thanks for your feedback.

            i checked the boards.... AAG27985-101


            so i have to think about to buy a e.g. Celeron G540 and try to update (and eventually kill the board), or to switch to another compatible Z77supplier directly and to return the Intel boards....

             

            will keep you posted.


            thanks again for your help !

            • 3. Re: DZ68DB Memory Error
              josh

              hi,

               

              update to latest bios version is done finally.

              first i tried to update using express bios update, unfortunately without succsess for every bios version.

              after the reboot the update should have been done but after checking the version in F2, the old version 0014 was displayed.

               

              iflash bios update.... files were not found (neither usb nor cd) while booting

               

              then i tried with F7.... "bios 0014 does not permit the F7 bios update process to be used. please update bios using iflash or intel express bios update...."

               

              as i did it before i updatetd to every bios version step by step (0014 to 0027 to 0029 to 0032 to 0040 to 0042 and finally 0043) using the F7 method. it worked

               

              at last it's possible to install the I7 3770 and new memory modules

               

              have a great day

               

              josh

              • 4. Re: DZ68DB Memory Error
                geoff_edj

                Hello Steve,

                 

                I recently bought a DZ68DB board to use with a 3rd gen i5-3570K processor.  How is it Intel tells me the board handles 2nd /3rd gen processors but comes with a bios (AAGxxxx-104) version not able to handle the processor which results in the memory error Josh described.  Apparently the only solution is what you recommend (find a 2nd gen processor to flash the bios) or return the board.  This strikes me a nothing short of stupid.  Certainly I am missing something. I read the link you provided, thank you, and remain flabbergasted that despite all the work I did to understand what Intel says is compatible really is not "out of the box" compatible.  What did I miss along the way?

                 

                Your thoughts?

                Thanks, Geoff

                • 5. Re: DZ68DB Memory Error
                  londonsteve

                  Hi Geoff,

                   

                  You're not missing anything - I was/am as exasperated as you. However Intel do not seem to be the only vendor to have Z68 based boards of which not all released variants support 3rd gen processors as delivered.

                   

                  When I worked at a PC builder many years ago, the need to upgrade by using a test processor would not have been an issue, but these days, no longer working in hardware and only building the occasional PC every few years for my own use. Not having spares to diagnose or work around issues with is very disconcerting.

                   

                  You may have read elsewhere that I lost patience with my DZ68BC board and bought a board from another vendor (which has been pretty much faultless). I will probably use the DZ68BC with the Celeron processor and some other memory that I had to buy (to diagnose issues with the board) to upgrade an old secondary PC.

                   

                  It seems extreme caution is now necessary when spec-ing these systems, but how to do that in this world of Internet ordering from box-shifters? You can't very well say one of those boards please, but only if the BIOS is Vx.xx or above!. Well you could, but I very much doubt if they could handle the query accurately. And to be honest who delves deep into support information before such a purchase to find the gory details before ordering. I'm generally very cautious, but in amongst all of the other research that I had to do on other new parts for my build, I missed that issue.

                   

                  So as such I too consider it unreasonable that the lower BIOS versions cannot even hobble along to upgrade the firmware.

                   

                  Good luck with your system.

                   

                  Steve

                  • 6. Re: DZ68DB Memory Error
                    geoff_edj

                    Steve,

                     

                    Thank you very much for the thoughtful reply.  I have tried to find a reliable indicator or tool to help me determine what board would have the right variant to support 3rd gen processors.  How do you go about ensuring what you order has it?  Do you simply go by the release date....i.e. anything in 2012 should support it?  And the question I have to ask...how did you arrive at the board you bought from another vendor?

                     

                    Thanks,

                    Geoff

                    • 7. Re: DZ68DB Memory Error
                      londonsteve

                      Hi Geoff,

                       

                      In INTEL'S case: On the third page of the document that I linked to above, there is a list of boards and relevant "AA" numbers. From memory, I think "AA" stands for "altered assembly" - it is a code for the particular exact spec of a product. If they change a part on a board, maybe add a resistor, change the value of a capacitor or even.....  (tada!) ship the board with a newer bios, the AA number is updated.

                       

                      The doc lists for each board, a "Capable" AA level and a "Ready" AA level - "Capable needs a bios upgrade, "Ready" just works (or not in the case of the "BC" board!!! grrrr!).

                       

                      There is other support documentation (spec updates and product change notifications) that list exactly what changes for each AA. But for our purposes the link above suffices.

                       

                      Usefully the AA level is printed on the box label - so you can tell what level a board was produced to without unsealing the box.

                       

                      As for other manufacturers - they all vary and some will not release such information. I went for a Gigabyte GA-Z77X-UD5 board in the end. I just checked that all bios versions supported either my i7-3770 chip or the celeron processor that I had, before I ordered... then I knew I could cope with an upgrade if it was required for stability. The only issue I've had with that board was with the raid config s/w for the Marvell controller. I've opted to use the slower ports on the Intel controller my secondary raid array as a result. Otherwise no issues whatsoever (relief!).

                       

                      Regards,
                      Steve