6 Replies Latest reply on Aug 30, 2012 11:03 AM by RobD

    DX79SR USB3 driver install problem

    RobD

      I've found that when installing the usb3 drivers to a Win7 x64 installation, that the installer sits for ages at 100% because even though the drivers did install, they could not start.

      Eventually after a few minutes the installer does complete. In device manager, the usb3 devices have moved to the usb catagory but still have an exclamation mark on them.

      Restarting the computer allows the installation to complete correctly [the installer does not request the restart], but the boot time of the OS has blown out from 20 seconds to nearly 2 minutes!

      Subsequent restarts yeilds no improvment in boot time, it sits for ages on the starting windows splash [logo is still animating - no freeze]

       

      Win 7 x86 is just as bad when it goes wrong, but so far 2 configs of the controllers and efi have worked correctly, meaning that the usb3 installer finished quickly and you would immediately see the 'installing devices' dialogs popping up [no restart required] with boot time remaining the same at about 20 secs.

      The two configs were with the boot drives connected to the Marvell controller in raid0 and the Intel controller set to raid with efi enabled and then disabled.

       

      The one config I want to work correctly is x64 in raid with efi on the intel controller and it's one config that yeilds the worst result!
      I think this board has just overtaken the Assassin for problems!!!

        • 1. Re: DX79SR USB3 driver install problem
          RobD

          Tried an install of win7 x64 to a single 2tb drive on the intel controller which was set to ahci with uefi enabled.

          The usb3 drivers installed fine with 'found new device' messages popping up.

          Boot time did not suffer like in previous post.

           

          Will try other configs at post back here.

          • 2. Re: DX79SR USB3 driver install problem
            RobD

            You wouldn't read about it!!

            Have tried every possible config of win 7 x64 to 2 x 2tb hdd's on the intel controller - ahci, non-raid raid and raid0 with efi enabled then disabled with all of them, and the only one that suffers a major blowout in boot time is the one I want to use - raid0 with efi! 

             

            With that config, the boot time nose dives from a fairly quick 20 secs, to a frustratingly tedious 1 min and 40 secs, most of which is with very little hdd activity.

            Also, when installing the drivers, they install fairly quickly on all configs except raid0 + efi, where it will sit at 100% for an inordinate length of time [minutes] with absolutely no hdd activity, to the point where your sure the system has hung.

             

            There was one interesting observation. On this last attempt, I rearranged the order in which I installed the first few drivers.

            Whereas previously I was leaving the installation of the usb3 drivers till after vga, this time I installed chipset, then EM, then usb3 front with a few restarts in between to check boot time.

            When I installed the usb3 front driver, this time the driver not only installed, but after the long wait at 100%, I had green ticked 'new device' messages popping up, unlike in my first post here where they installed but failed to start.

             

            Wether this was because of the change in order of driver install, I can't say for sure, but it was a small step in the right direction which did create some excitement in me, but that was soon shot to pieces when I did a restart and the boot time was still insanely slow.

             


            • 3. Re: DX79SR USB3 driver install problem
              RobD

              As I've mentioned in another thread, install win updates before usb3, lan and wifi drivers, then all works sweet.

              • 4. Re: DX79SR USB3 driver install problem
                RobD

                I've revisited this issue with 2 x 2tb hdd's on the intel controller in raid with efi and it's still the same problem when installing usb3 or lan drivers before win updates, in fact this time it really screwed up and errored out as per below pics.

                 

                This pic is the error at the end of installing usb3 front, after waiting the usual eternity at 100% progress

                 

                usb3 error1.JPG

                 

                Then after clicking the ok button

                 

                usb3 error2.JPG

                • 5. Re: DX79SR USB3 driver install problem
                  rbmorse

                  Rob, I don't have a lot of experience with Renasys drivers, but I did have a Silverstone PCI-e USB 3.0 expansion card in an older machine built around a Renasys controller and my experience was identical to what you describe. 

                   

                  If the driver package your machine uses is similar to what I had, running setup.exe from the main package extracts its contents to a working subbdirectory. Within that subdirectory there will be separate folders for several different controllers. If that's the case, you'll have to find the correct folder for the controller in your system  (mine was a uDP720202) and install the driver from there.

                   

                  Wish I could be more specific, but I hope this helps in some small way.

                  • 6. Re: DX79SR USB3 driver install problem
                    RobD

                    Hi, thanks for your input. I'm not sure that this is the case here, you can see the folder with all the files in the background inc. setup.exe.

                    The archive you download from intel is just a self extracting exe with all those files in it. It then runs setup automatically after the extraction.

                    As noted above, it's only raid with efi that falls over, all other configs of hdd[s] work prefectly.