1 Reply Latest reply on Aug 1, 2012 11:50 PM by corvid

    Intel Rapid Storage Technology driver causing BSoD

    Terry Prins

      Hello everyone, thanks for taking the time to read this. I apologize if this is posted in the wrong place, I felt this was the best place to start.

       

      I have an Asus Maximus IV Extreme-Z Motherboard with an Intel Core i7-2600K CPU, and I was having a couple of Stop Errors happening recently. I noticed that after a system reboot, none of the Blue Screen memory dumps were being put into my Minidump folder (even though it is enabled in system properties). After some google surfing and talking to some friends, this can sometimes happen if a RAID driver is not installed properly. Immediately I went to the Asus website to install the appropriate driver, the "Intel(R) Rapid Storage Technology Driver Software V10.6.0.1002 for Windows" driver from their website, but the driver causes a Blue Screen stop error with the code 0x0000007E, caused by driver "iaStor.sys".


      I decided to do a clean install of windows and install all the drivers from scratch before attempting the IRST driver again. Same result, a blue screen. I also tried to use Intel's driver update utility to see if there is a more recent version of this driver on intel's website, but it doesn't show the driver in the list. I've also tried searching manually.


      Can anyone help me with this problem? If so I would be very appreciative, Blue Screens are preventing my computer from being useful.


      Thanks again for your time!

        • 1. Re: Intel Rapid Storage Technology driver causing BSoD
          corvid

          Terry,

           

          I’ve been Googling this topic too since I had a similar problem while rebuilding a laptop. Let me see if I can help you with what I’ve learned so far.

           

          I’m guessing you are referring to a “STOP 0x0000007B” BSOD error during boot up that happens after installing the Intel Rapid Storage Technology driver. This will happen if you SATA controller is not set to RAID mode when you install the IRST driver. By default most BIOSs set the controller mode to AHCI. This may have happened if your BIOS got returned to defaults. Also, if the controller mode is changed from the mode it was in when Windows was installed it will BSOD. Now I will explain the fix that worked for me.

           

          First you need to get Windows Booting again. If you don’t know what the settings were when you Installed Windows this may take some trial and error. If you are getting the BSOD because you installed the IRST driver, try booting to the last known good configuration. If that doesn’t work, also try switching the mode of your SATA controller to AHCI or RAID. You may have to try switching modes and boot to last known configuration one way and then try it the other way. If you still can’t get windows to boot you may have to just set your controller to RAID mode and reinstall Windows.

           

          Once you are back into windows you need to get windows to boot with the controller set to RAID mode. If this is already the case go ahead and install the IRST driver. If not, follow the instructions here: http://support.microsoft.com/kb/922976. Basically you need to set the following registry key to “0”

          HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV

          After you make the change, restart and go into your BIOS and change the SATA controller to RAID mode. Windows should successfully boot back up after this. Now you can install the IRST driver. Once you have installed the driver and rebooted again you can go ahead and setup whatever RAID configuration you want. Or you can continue to use them as independent disks, but now you have the driver installed.

           

          When I had a problem I ran into additional problems with an old RAID configuration I can post more details about that if it’s helpful but this post is long enough. Let me know how it goes.

           

          Oh yah also, a similar post is here: http://communities.intel.com/message/160599