6 Replies Latest reply: Jul 27, 2012 7:34 PM by clemc RSS

    Installing RST causing BSOD at startup (Intel 520 Series 120GB)

    clemc

      Ok, a bit of back story.

       

      I was (still am) getting blue screens at start up.  What would happen is; I'd start up the computer and after about 2-3 minutes (sometimes more, sometimes less) Windows would freeze and after a few seconds I'd get a bluescreen and the computer would restart.

      Once the computer had restarted (sometimes this involves a startup repair), the PC would be fine, I could put full load on the CPU, GPU and RAM without any issues, the PC seemed to run fine.

       

      After a heap of troubleshooting, I discovered it was one of the drivers on the motherboard CD causing the issue. I finally narrowed it down to the Rapid Storage Technology driver.

       

      Before I install the RST driver, the system starts up fine and runs fine. When I install the RST driver (I've tried the latest v11.1.0.1006), I start to get the blue screen issue.

       

      I've run memtest multiple times and it hasn't found any memory errors. Intel v3.0.3 Toolbox tells me I've got the latest firmware.

      I've updated my BIOS and set the SATA to AHCI.

       

      I've done a bit of Googling and this doesn't seem to be a rare problem (with 520 Series drives), so I'm seriously considering going with a different drive.here

       

      Is there something I should try before I ask for a refund on this drive?

       

      Is this a sign that the drive may just be faulty?

       

      My Specs:

       

      Windows 7 Ultimate 64 bit SP1

      Intel 3570K

      ASRock Z77 Fatal1ty Professional

      16GB (4*4) G.Skill DDR3 @1600MHz 9-9-9-24

      ASUS GTX 670 DirectCU II

      Corsair AX750

      Intel 520 Series 120GB SSD

        • 1. Re: Installing RST causing BSOD at startup (Intel 520 Series 120GB)
          clemc

          I don't have any other SSDs, but I installed Win7 onto a HDD (old WD 80GB 60MBps drive), installed RST and was able to boot up (multiple times) without getting any blue screens.

          Not sure if this is any help, as I was using a HDD and not an SSD.

          • 2. Re: Installing RST causing BSOD at startup (Intel 520 Series 120GB)
            parsec

            I've used several versions of IRST with 520 SSDs, and have never had a problem with BSODs, etc. Did you run the System Tuner in the Toolbox? I would also suggest setting the Windows power profile to High Performance when using SSDs.

             

            The latest version of IRST for Z77 boards is 11.2.0.1006. If your board manufacture has not provided that in their downloads, you can get it directly from Intel.

            • 3. Re: Installing RST causing BSOD at startup (Intel 520 Series 120GB)
              clemc

              Ok thank you, I'll try those tips.

               

              This the correct drivers?

              Download Center

              • 4. Re: Installing RST causing BSOD at startup (Intel 520 Series 120GB)
                clemc

                I installed this version of RST and have been able to reboot 6+ times without a BSOD. I reinstalled the OS and loaded that driver thing while I was doing so.

                 

                Thank you very much for the help, I probably wouldn't have found out about that newer driver if I wasn't told about it (I wasn't using the download center correctly, but now know where I went wrong).

                 

                I won't call it just yet, but before I was lucky to get one boot without a BSOD, I've now gotten at least 6, so this is looking good.

                 

                I'll post back in a couple of days, unless something happens before then.

                • 5. Re: Installing RST causing BSOD at startup (Intel 520 Series 120GB)
                  parsec

                  One other thing to keep in mind is the UEFI/BIOS version used with your board. I've been using an ASRock Z77 board recently, and they seem to be having a few odd issues with the UEFI/BIOS for their boards. If you are using an older version of the UEFI, I would consider updating to a newer version.

                   

                  My ASR board has a UEFI update that also contains a new Intel Option ROM, that is used to configure RAID and SRT configurations. You should check that your board has a similar update.

                  • 6. Re: Installing RST causing BSOD at startup (Intel 520 Series 120GB)
                    clemc

                    I've gotten another four BSODs. The blue screens are less frequent then they were, but I'm still getting them.

                     

                    I installed the latest BIOS (which was released about 10 days ago), set power options to high performance, but nothing has completely stopped the blue screens.

                     

                    The last four BSODs were:

                    CRITICAL_OBJECT_TERMINATION

                    0x000000f4

                     

                    CRITICAL_OBJECT_TERMINATION

                    0x000000f4

                     

                    BAD_SYSTEM_CONFIG_INFO

                    0x00000074

                     

                    CRITICAL_OBJECT_TERMINATION

                    0x000000f4

                     

                     

                    I'm not going to waste any more time trying to get this SSD working, I'll just get it replaced. Thanks for the help.