4 Replies Latest reply on Jul 25, 2012 7:07 AM by RobD

    Intel DX79SI RAID not able to install w7x64 - 0x80300001 error

    Karel Krupala

      s7ssiHi,

      board bios 0525

      RSTe Driver - tried from MB CD 3.0.0.1112, from web 3.0.0.3020, 3.1.0.1085

      2 WD1003FBYX in RAID1

      installing w7x64 in AHCI mode - no problem. After switching BIOS to RAID, preparing 2 WD1003FBYX HDD to RAID1 and trying to install, the installer asks for the drivers. Loaded the drivers from USB flash disk. Installer found new volume, but below is the hint saying, that

      "Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu." I can create partition, tried to create 100MB and the second rest, but when i click the Next button, installer says, that is not able to create partition and write to disk and the hint is still on.

      I tried to connect the drives to black ports, blue ports, tried to install third drive as standalone boot system drive (not included in RAID array, first boot device), the same problem (in this configuration, the installer wrote the error 0x80300001 error). Tried 494 bios, tried tricks with diskpart and manually creating the partitions - no chance to install the system with RAID.

      After switching to AHCI, installation finished without any problem.

      Tried another MB (Gigabyte GA-EP45-DS3R), these drives were installed in the configuration 2xWD1003 in RAID1 and 1xWD1500HLFS standalone, installed without any problem, so the problem is on the MB or drivers.

      Please, does anyone similar problem or knows the solution?

      Thanks.

        • 1. Re: Intel DX79SI RAID not able to install w7x64 - 0x80300001 error
          Victor_Intel

          Hello Karel


          I understand that you are not able to install the operating system in to your RAID or stand alone hard drive and that Windows* gives you an error to turn on the controller.


          In regards to your inquire, you need to check on the UEFI setting in BIOS. EFI needs to be enabled in BIOS under the boot tab to be able to use hard drives larger than 2TB.


          Regards .


          PV

          1 of 1 people found this helpful
          • 2. Re: Intel DX79SI RAID not able to install w7x64 - 0x80300001 error
            RobD

            I had the same issue with the exact same error code on a gigabyte G1.Assassin 2 m/b which has the same chip setup, but maybe for for slightly different reasons, but my experience may give a clue.

             

            I had the hdd's connected to the marvell controller in raid and at the point were your asked to provide the f6 driver, I removed the win setup dvd and inserted the Assassin driver cd, browsed to the f6 x64 marvell driver and it installed without issue.

            The raid array was now visible but with the error 0x80300001.

            I then discovered that it was because I had removed the win dvd to load the f6 driver from the cd and setup was simply waiting for me to re-insert the win dvd.

            When I re-inserted the dvd and waited for the drive to mount it again the error disappeared and the install was able to proceed.
            So, if you are always loading drivers from a flash drive, then I have no answer to why this is happening to you, but be aware of this quirk when using a driver cd instead of a flash.

             

            Also, I have discovered that some times you may need to click in an empty part of the drives window, then click back onto the drive you want to install to, to make the error disappear.

             

            I have also discovered that you can only install from a driver cd [this intel board or the assassin board] when you use the marvell chip.

            When installing raid to the intel chip, the dvd drive is not present when you click browse.

            This issue seems to be because of the point during initial setup, that you are presented with the window that asks for the f6 drivers.

             

            With the marvell chip, you get the eula first, then the customise screen, then after clicking that you get the f6 browse screen and the dvd drive will be visible as D drive and you can load f6 drivers from cd or from flash.

            With the intel chip, you get the f6 browse screen before the eula and at this point, win setup has not yet loaded an extension and driver [like the old mscdex and oakcdrom.sys cd drivers] to make the dvd drive available.

             

            Here's yet another 'gotcha'. Beware of swapping raided drives from one chip to another without first deleting the volume using the current chips utility before connecting them to another chip.

            My experience here with this intel board [mine is actually the SR model] is that I first connected two drives to the marvell chip and set them up in raid, then moved them to the intel chip and recreated the raid on the intel chip, but found i had an issue with loading the intel f6 drivers, though discovered that the later version 3.1.0.1085 did work.

             

            I then moved the drives back to the marvell chip and was surprised to see that marvell still saw them as already configured and still with the same name that I had assigned to the volume.

            Ah-ha, I then had a clue as to how my lack of attention to detail may have caused the intel f6 driver issue.

             

            I then deleted the raid volume using the marvell chip, then reconnected them to the intel chip and this time the older 3.0.0.3020 f6 intel drivers loaded without issue.

             

            Victor_Intel, it has been my experience so far that if uefi is not enabled, you can still install x64 to a raid volume greater than 2tb, but any space above 2tb will be lost.

            It is the same for x86, but of course, x86 does not support uefi so it doesn't matter if it is enabled or not, but it is still the same scenario.

            The OS will still install to a raid array greater than 2tb, but all space over 2tb is lost.

            • 3. Re: Intel DX79SI RAID not able to install w7x64 - 0x80300001 error
              Karel Krupala

              Hello Victor_Intel and RobD,

               

              thank you for your advice. I thought that UEFI is needed for the drives over 2TB. My boot drive is 150GB, but i tried it. At first there was the same error. After that i tried the advice from RobD with loading drivers from CD instead of USB flash disk and reloading the original install dvd with windows setup after that and the error message disappeared!

              I tried to continue with the setup than. Setup informed me, that it will change the mbr, because of UEFI. Then started instalation, but after few steps it freezes. Now becomes the most interesting part. I read again the RobD advices - that it is needed to remove RAID volumes on the old chipset before installing on the new one. Even if this boot drive was not in the raid volume, but there was installed windows on another chipset before i tried to reset UEFI back to disabled and install again. Such a surprise - without any problem!

              So, the problem was IMHO with the MBR (even if i cleaned it in the cmd with shift+F10 during setup).

              Thank you both, gentlemen!

              • 4. Re: Intel DX79SI RAID not able to install w7x64 - 0x80300001 error
                RobD

                Hello Karel, I'm glad my many hours of tinkering with these motherboards has help you out.

                I only need one person to have benefited and it is all worth while. 

                It's now been more like days, heading into weeks, of installing win7 x86, x64, to this chip,that chip, raid, non raid, less than 2tb, more than 2tb, this driver, that driver, usb, cd .....and on...and on!!! God I am so tired of installing windows!!!

                 

                When raid chips first hit the market, I approached with caution, but have found it to be very reliable, though I will only ever use it for boot drive, not data. I keep data on single disks with 'old school' mbr so they can easily be moved to another system if needed.

                 

                But now with raids greater than 2tb using gpt with uefi bios, I'm back to super cautious!! The whole thing seems a little flaky and error prone, especially when swapping between different chips, even when strict 'best practice' is employed.