1 Reply Latest reply on Jul 19, 2012 1:00 AM by vsespb

    DP67BG + i7-2700K no post, 2nd RMA?

    Roger

      In December I purchased a DP67BG motherboard and an i7-2700k processor from intel (the $230 deal), received my items, ran into ERROR 27. No post, won't boot, can't get into BIOS to do BIOS updates (tried using iFlash to flash an update for BIOS but it won't get into BIOS), etc.

       

      I had M378B5673DZ1-CH9 Samsung Ram in my old computer (HP desktop), which is one of the "compatible" ram sticks for the motherboard. I also have CMP16GX3M4A1333C9 Corsair RAM as well. I have an old PSU from my HP desktop, and a new PSU 600W for my new setup.

       

      The MOBO and the CPU are the only 2 components of my setup that I cannot be sure are working properly. Both PSU's work with old MOBO/CPU, both sets of ram (all work fine, all ram modules show, and still show as I tested after they didn't work in the setup) work, and all the rest of my components like HDD's, SSD's, BluRay, Graphics card, all work fine as well.

       

      Tried the setup with just the PSU, CPU, Mobo, and the RAM to see if that would work. Ram in DIMM 1, then DIMM 2, then DIMM 3, then DIMM 4. DIMM 1 and 3, DIMM 1 and 4, DIMM 1 and 2, DIMM 3 and 4, DIMM 1, 3, 4, DIMM 1, 2, 3, DIMM 1,2,3,4, etc. etc. etc

       

      Tried swapping the RAM into different DIMM slots, like RAM A B D C for Corsair, Tried each module A B C D singular in DIMM 1. Also did RAM A B C for Samsung in as well, singular, in DIMM 1

       

      The RAM is 100% perfect, no errors, did a memtest on my RAM. Futureshop says my RAM is perfect. I know the RAM is PERFECT. I mean PERFECT.

       

      The MOBO was RMA'd the first time for this exact problem. I get another one, and now the same problem, 3 BEEP / Error 27.

       

      What should I do or try?

       

      I am thinking that people say some PSU's don't work well (even if it's just the RAM, CPU FAN, PSU, CPU in the setup). Without a graphics card it shouldn't require more then 600 just to post into BIOS should it? Or is it just maybe some weird requirement that only certain PSU's work?

       

      The RAM controller in the CPU actually defective? The first time I sent it out, we figured it was the mobo giving RAM problems (since Futureshop tried 6 Sets of RAM and 4 PSU's in their setups too), could it be the i7-2700k processor that is defective giving the error 27 to the MOBO. I'm not all up on my info but apparently the RAM controller itself isn't in the MOBO but in the CPU?

       

      RMA again and hope for the best? Spend another $60 on UPS shipping?

       

      rogerkelsey@hotmail.com if you know a solution!