5 Replies Latest reply on Jun 17, 2013 2:46 AM by Marco Gulino

    DZ77SL-50k + UEFI + Linux = no boot

    Marco Gulino

      Hi everybody

      As suggested by the topic title, i tried booting linux with my DZ77SL motherboard, in UEFI configuration.

      I can launch boot managers (refind, grub), but upon launching kernel the system freezes after the "loading initial ramdisk" message.

      I tried launching kernels from grub, from refind (efistub) and even directly by efi shell.

       

      Any suggestion?

      Thanks

      Marco

        • 1. Re: DZ77SL-50k + UEFI + Linux = no boot
          Tolga

          UEFI is still broken at the moment. Linux and Intel Series 7 Mainboards don't like each other; its a bloody mess right now - I would recommend you going for legacy boot until they got finally UEFI fixed and then switch over. It's probably going to be fixed in the next BIOS update, but you never know. So, if you're depending on Linux, legacy boot is the way to go for now. I honestly regret beeing an early adopter...

          • 2. Re: DZ77SL-50k + UEFI + Linux = no boot
            Martin S.

            Yes, I have a same issue with DZ77RE-75K. UEFI and Linux is NoGO at this moment. I also regret buying this board.

            • 3. Re: DZ77SL-50k + UEFI + Linux = no boot
              dislikeyou

              I had problems booting Ubuntu in live mode from a USB stick. I got some error and a black screen. Don't remember exactly what the error was. Boot without UEFI: and it will work.

              • 4. Re: DZ77SL-50k + UEFI + Linux = no boot
                mks

                For the record: since BIOS version 89 (possibly 87 as well, I skipped that version) I have been able to boot Linux in UEFI mode without problems.

                • 5. Re: DZ77SL-50k + UEFI + Linux = no boot
                  Marco Gulino

                  More or less yes, I tried too, now linux can properly boot in UEFI mode.

                  However the boot is very very unstable: I can't properly add a new boot entry neither using efibootmgr nor bcfg in the UEFI shell. Or better, I can add it, it's stored in NVRAM, but the boot menu simply doesn't see them.

                  I could boot the default uefi entry (/boot/bootx64.efi), but sometimes it disappears: when I change the boot order in bios setup, the UEFI partition is not seen anymore in the next boot.

                  Beside, I can't get to boot a windows 7 or 8 dvd in UEFI mode (and I though that at least windows should have been very well supported...)

                  And trying to enable Fastboot make things even worse...

                  The bios is very unreliable, it really needs to be worked on...