3 Replies Latest reply on Jul 8, 2012 9:06 PM by tiagovaldo

    Centrino Advanced-N 6230 driver properties does not show 802.11n Mode option

    tiagovaldo

      Hello All,

       

      I have a Dell XPS 15 (l502x) that came bundled with Centrino 1030. This card works perfectly, detects all networks, can connect to N networks just fine.

       

      I have recently updated my router to a Asus N56U, which is dual band and thus, decided to upgrade to a Centrino 6230 card so I could use all the new rounter could give. So, I uninstalled Intel drivers, turned the notebook off, swapped the cards, booted windows back again and installed Intel drivers again.

       

      Now to the odd part. Although I'm using the same driver version (15.1.1) from Intel website, with the 6230 card I can't see the option to enable 802.11n network mode, and thus, can't connect to any "N" networks. On Intel ProSET software, all networks that are N, only shows the "G" icon and my 5GHz network shows only the "A" icon. Even worst is that if I connect to a G or A network, then the card won't get a IP from the router, regardless if I try a 2.4GHz or a 5GHz network.

       

      With the old 1030 card, none of the above happens, and I can connect to my 2.4 GHz N network just fine.

       

      I have tried to change all settings from the router and still no good. I'm suspecting this is a hardware issue, but wanted to confirm this is not a known driver issue or if there is something I'm missing out before I send the card back to the retailer for an exchange.

       

      All the best,

      Tiago