4 Replies Latest reply on Jul 6, 2012 7:37 AM by john_s@intel

    SASWT4I raid controller not allowing configuration


      Hi all,


      I have an SASWT4I raid controller with a DX79SI motherboard and Xeon e5-2620 CPU and am having trouble configuring the raid controller. The four SATA Hard drives (WD1003FBYX) attached to the controller are detected correctly and I can enter the controller configuration utility but the 'RAID Properties' option is grayed out and gives the following message when selected.

      This field is grayed out under the following conditions

      - The adapter's MPT FW does not support the feature.

      - There was an error retrieving non-volatile RAID information on this adapter.

      - The non-volatile settings for this adapter are configured to disable all supported RAID array types.

      I have upgraded the firmware and bios on the card to the latest versions.

      After installing windows on an additional hard drive I am able to use the web configuration tool to configure RAID 0 and 1 on this adapter but I am trying to get RAID 1E


      Any ideas why I can't get to the RAID properties menu to configure RAID 1E?




        • 1. Re: SASWT4I raid controller not allowing configuration



          Where are you getting the list of causes for the grayed out RAID Properties field?


          I tried the SASWT4I in a W2600CR here in the lab and was able to go into the RAID Properties even without HDDs connected and it worked fine. That was a new "out-of-the-box" controller and likely was running older firmware.


          Can you try with no HDDs attached?


          I can't think of anything that would prohibit creating a RAID array with the BIOS configuration utility. And if you can create a RAID 0 and 1 array in the web console, you should be able to configure a 1E. The controller supports RAID levels 0, 1 and 1E.




          • 2. Re: SASWT4I raid controller not allowing configuration

            Hi John,


            Thanks for your reply.


            The list of causes shows up when I select the RAID Properties field.


            The board I am using is a desktop board, DX79SI, should this RAID controller work in a desktop board?


            I have just tried the BIOS configuration utility with no HDD's attached and the RAID Properties option is still grayed out and presents the same list of causes.


            The web console only gives RAID 0 and 1 as options. Is there an updated version of the web console that I should be using that might include the option for 1E?


            Any other suggestions or things to try?




            • 3. Re: SASWT4I raid controller not allowing configuration

              After installing the latest Web console and re-flashing the firmware and bios using the web console, I was able to configure a RAID 1E array and can now access and configure the RAID Properties via the BIOS configuration utility.




              • 4. Re: SASWT4I raid controller not allowing configuration

                Glad to hear you got it working David.


                When you were attempting to configure the RAID in the BIOS Console, did you notice what firmware versions was reported in the console screen top banner? I'm just wondering if the first firmware upgrade simply didn't take. I should have asked about that.