2 Replies Latest reply on Aug 23, 2012 11:38 AM by piotr bagniewski

    Intel 2230 wifi association issue with WPA2/AES


      Just bought a Dell Inspiron 15R (model 7520) with Intel 2230 wireless-n AND a new Netgear N600 (model DGND3700).  I was finding that initial setup went well on the 2.4GHz band, but everytime I lost connection between router and PC (router or PC restart), wireless connectivity would not re-establish.  Issue ranged from seeing SSID but not able to connect, or not seeing SSID at all.  I upgraded router firmware and PC driver (from Intel site as not on Dell site yet), with no change - including removal and reinstallation of driver.


      I worked out that if I connected the PC via cable and deleted the wireless network on the PC, and rebooted everything, the issue was temporarily resolved.  The PC would find the SSID and reconnect.  But doing this every time was more than annoying.  Feels like something at some layer is being cached, or leaving something resident preventing reconnection unless I re-establish connectivity to the router via cable, clean up and start again.


      My other Dell notebooks, PS3, Wii, Apple devices, and my Android and Blackberry Phones were all OK (noticed only the iPad could see the 5.8GHz network) - with router configured for WPA2/AES.


      After bashing head on table for a week I finally tried reconnecting the PC to router using the Wifi Protected Setup (WPS - Netgears Push 'n' connect).  This worked - only now the wireless network on the 15R shows up as WPA2/TKIP ?!?!  I don't know if this is the final working solution yet - only worked this out this week.


      Is there an issue with AES on the 2230 chipset?  Is there an issue with the driver caching something that is preventing full release of config/connection information when connection is lost or PC wifi network is recreated?