1 Reply Latest reply: Jun 28, 2012 4:03 PM by MBV2000@intel.com RSS

Debugging unable to send desktop to display

maxp Community Member
Currently Being Moderated

Like many others I see this error when connecting, but no solutions:

 

I have installed the latest version of all drivers (WiFi, Intel HD4000, WiDi Software). When I scan for devices I see my D-Link-131 Mainstage Adapter. On first connection I was prompted to enter a security code. This went fine. However, whenever I try to connect it says 'unable to send desktop to display'.

 

The sequence is:

I see it attempt connect.

The mainstage says connecting, then connected.

I see my PC switch graphics mode

I get prompted to update the firmware

The PC then switches mode again - screen blanks out - about 2-3 seconds after it connects  and I get the 'unable to send desktop to display' message.

 

I have checked:

 

The Windows firewall settings - all appear fine.

The My-WiFi devices list - it sees the mainstage.

Resetting the firmware on the mainstage - no difference except it is now set to Greek or Russian!

Switching between g and n on the wireless settings

Moving the adapter as close as possible

 

Nothing gets rid of this error. NB when it prompts to update the firmware but it says 0 of 0 files, 0% - then fails the update. Presumably this is because it has dropped the connection.

 

This is very frustrating.

 

1) Is there any way to update the firmware without trying to send the display to the adapter? The firmware is quite out of date, looking at the quoted version numbers.

2) Are there any logs or debug information written that I can look at? (i.e. the graphics driver, WiFi software or WiDi software)?

3) Is there a debug version of the WiDi software I could try?

4) Why does the firmware update say 0 of 0 files? Surely it should indicate there is a file to update or upload?

Can anyone post a screenshot of what the successful firmware update process looks like for the 131?

 

Right I'm pretty depressed, since I've tried everything I can think of to get this to work.

 

I really hope someone can shed some light on what is failing.

 

Many thanks,

 

Max

  • 1. Re: Debugging unable to send desktop to display
    MBV2000@intel.com Community Member
    Currently Being Moderated

    The first recommendation that I can give you is to confirm if your computer actually support Wireless display, the software needs to be pre-installed in your system in order for it to work. The OEM manufacturer of your computer can help you with that.

    Regarding the Firmware update question, I suggest you to contact D-link for assistance on how to update the firmware of the wireless receptor (D-Link-131).

    Note that if your system has the option to switch between onboard graphics and a graphics card, you need to make sure that the Intel graphics are selected before you use the Wireless Display option.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points