1 2 Previous Next 20 Replies Latest reply on Jul 21, 2012 10:41 AM by Ken Jongsma

    DZ77GA-70K + BIOS version 0045 - issues

    radan

      I decided to create this new topic as it might be considered more general. I recently bought DZ77GA-70K and unfortunately I haven't checked what BIOS version had been on. I also made some BIOS version changes and I noticed several strange behaviors as none of the current versions seem to be completely OK / bug free. I will also create a new support ticket w/ intel however it's nonsense to do that during the weekend.

       

      Just for the record, these are my current components used in my pc:

      • DZ77GA-70K
      • Intel Core i7-3770 (this is not the K version because of VT-x support needed)
      • Corsair Vengeance Black Low Profile 16 GB (2x8GB) - part. no [X0] CML16GX3M2A1600C10
      • Intel SSD 520 - 120GB
      • GIGABYTE GTX 560 Ultra Durable OC 1GB

       

      BIOS 0045

      I tried to update to the latest version of BIOS. When I did that, I experienced these issues:

      • There were all devices connected to SATA ports visible, however under the list in main BIOS page was a message that there is no SATA device detected / available or something like that
      • I was unable to boot to any of my connected devices using either EFI or UEFI, ACPI or IDE mode. I haven't really tried RAID option but I don't believe that was the case
      • BIOS does not show current temperatures and voltages

      Troubleshooting: I tried several options, combinations of config settings, tried to reset BIOS to default 3 times including updating the BIOS 0045 again, nothing worked for me. Of course I tried to manually select BOOT device, nothing worked.

       

      Not sure why, but when I use this BIOS version, I cannot boot to any device so from that point this BIOS is useless for me. After an hour or so I gave up and downgraded the BIOS to 0039 - described bellow.

       

      BIOS 0039

      When I have this BIOS on, I can make it working, however w/ only few options.

      • EFI boot does not work (similar behavior to the BIOS 0045) - have absolutely no idea why
      • UEFI option is the only one that I am able to boot with to any of my connected devices
      • PC runs Windows 7 64bit, all drivers available on intel support page are installed, however I can see these devices not installed and/or with issues: Microsoft PS/2 Mouse (Hadrware ID: ACPI\PNP0F03), PCI Simple Communication Controller (Hardware ID: PCI\VEN_8086&DEV_1E3B&SUBSYS_20378086&REV_04) - please note I disabled the PS/2 port in BIOS and it's still there anyway
      • I am unable to install Intel Desktop Utilities v. 3.2.2.046. After the installator starts and performs initial check, it ends up w/ error message that this software can be installed only with Intel mainboards. In this post dislikeyou mentioned that it is related to UEFI mode and OS installed w/o UEFI support. I am not sure how to install Win7 w/ UEFI support at this point. I will try to find it out.
      • BIOS does not show temperatures or voltages (similar to 0045)

       

      I was tired and haven't really tried any older versions. Is there anyone w/ some other or similar BIOS issues and this particular mainboard? Any help or at least a tip would be highly appreciated.

        1 2 Previous Next