2 Replies Latest reply on Jun 12, 2012 10:07 PM by Heba

    Frequency Scaling

    Heba

      Dear All,

       

      I'm facing a problem with frequency scaling on the scc cores.

      After I set the frequency to the required value for example 800 Mhz, it succeeded for just some second, and then the core return to its original frequency automatically. I knew that when I "cat" the file cpu_cur_freq. It contains the new value of the frequency just for second, and then it changes automatically. This happens with the new sccLinux 3.1.4 . Knowing that it succeeded with the older linux kernel.

       

      So, could anyone help in this problem ?

       

      Thanks in advance,

      Heba

        • 1. Re: Frequency Scaling
          mwaughex

          Hello Heba,

          So the procedure you are using to set the frequency worked on the older kernel, but the same procedure does not work with the new sccLinux 3.1.4.?

           

          Could you please provide some detailed information on how you set the frequency?  I would like to replicate the problem in the MARC lab.

          • 2. Re: Frequency Scaling
            Heba

            Ya, the procedure that I'm using to set frequency worked on the older kernel.

            to change the frequency of the tile, I write to the Global Clock Unit (GCU) Configuration Register (the address is 0x80) the wanted value, for example, to make the frequency 100 Mhz, I write "0x0380eff0" to the address 0x80.

            If I soon read the curr_cpu_freq file, I'll find 100 . However, when I read this file after a few seconds, it will change automatically and return to the origin frequency of the core, for example 533.

             

            I hope that I could clarify the problem.