11 Replies Latest reply on Jun 6, 2012 8:50 PM by cejurgens

    New 3570k not booting.


      I just purchased a new i5-3570k to build a new system. I assembled it all this morning, but it will not boot. When I press the power button it lights up and runs for about one second then everything stops. The red LED light on my motherboard that is for the CPU comes on. I have tried starting it with just one stick of RAM and no other hardware attached with the same result. I have also tried to start it outside of the case with no luck. I do not have another motherboard or processor that I could test with. Is there anything else I could try?


      The hardware I am running is:

      Asus Sabertooth Motherboard


      16gb of Corsair Vengeance RAM

      Rosewill 630w PSU

      1.5tb HDD

      Asus DVD Drive

      Nvidia GT 460

        • 1. Re: New 3570k not booting.



          Just to check, have you plugged the 2x4 pin 12 volt connector to the motherboard?





          • 2. Re: New 3570k not booting.

            Yes I have.

            • 3. Re: New 3570k not booting.

              I'm assuming this is the P67 board? This looks like a BIOS problem. According to the Asus website, the i5-3570K requires BIOS version 2302 or later. If you have an older board (like one that has been in somebody's inventory for a long time) you'll have an older BIOS.


              The i5-3xxx processors are 3rd generation Core processors (code named Ivy Bridge). The Sabertooth was originally designed for 2nd generation Core processors (code named Sandy Bridge). They both use the same socket and a board can be designed to accept either generation but a new BIOS will be required to support the newer processors.

              • 4. Re: New 3570k not booting.

                I have the Sabertooth Z77 board, sorry I didn't mention that clearly. I think the BIOS may be the problem, however I cannot figure out how to update it. I have the flashback usb BIOS on my motherboard and I know how to use it but I can't get it working. I know my two problems are that I don't know what to name the file, and I don't know how to save to the root directory of a flash drive. I think the file needs to be named SABERZ77.ROM and I can save it anywhere on the flash drive as long as it is formatted to FAT 32, but I have had no luck getting it to update. Any help?

                • 5. Re: New 3570k not booting.

                  I think the original BIOS on the Z77 is supposed to support the i5-3570K, but using the latest BIOS is a good idea anyway. Do you know what version of the BIOS is currently being used?

                  I'm not sure about the file name, although that's probably correct. Also, the file can't be anywhere on the flash drive but must be in the root directory. What happens when you try to do the update? What does the LED do?



                  • 6. Re: New 3570k not booting.

                    I downloaded the latest BIOS version from the Asus website. Can you explain how to save to the root directory?(I have not found anything helpful on google) The LED comes on and stays on indicating that the BIOS update failed.

                    • 7. Re: New 3570k not booting.

                      OP,  try this if you haven't already.


                      Unplug the 4 or 8 pin (whichever you have) connector on the motherboard near the CPU.  Then turn on the computer.    Does it turn on and stay on?

                      • 8. Re: New 3570k not booting.

                        Unplugged the four and got the same result. Thanks for the suggestion though.

                        • 9. Re: New 3570k not booting.

                          I think our assumption about the name of the BIOS file is wrong. Use Z77ST.CAP. See if that works.

                          • 10. Re: New 3570k not booting.

                            Ended up returning the motherboard, it was dead. CPU is working fine now on new board.

                            • 11. Re: New 3570k not booting.

                              Glad you got it resolved. That would have been my next suggestion, although I'm surprised that a high-end motherboard from Asus was DOA. It does happen, though... obviously! Enjoy!