9 Replies Latest reply on Jun 26, 2012 10:07 PM by daly

    Intel 520 SSD can't set password


      According to the product brief:


      "The new Intel SSD 520 Series offers the best security features of any Intel® Solid-State Drive to date and comes pre-configured with Advanced Encryption Standard (AES) 256 bit encryption capabilities. In the event of theft or loss of your computer, you have the peace of mind that your personal data is secured by an advanced encryption technology."


      I have used this feature with an Intel SSD 320 in my ThinkPad W520 laptop. I was able to set a user and master password.


      However, when I put my new Intel SSD 520 (SSDSC2CW480A3) into the same laptop, I'm unable to set a user and/or master password.



        • 1. Re: Intel 520 SSD can't set password



          Intel seem to be playing fast and lose with their advertising of encryption abilities on their SSDs as they fail to point out to be any good requires motherboard support.  There is no peace of mind if you can't set a password on it and several of us are still waiting for support on their own motherboards!  So not too surprising you have issues.


          Is the 520 a replacement for the 320, i.e. in the same physical slot?  Have you swapped from IDE to ACHI mode at the same time as swapping them?


          Did you cancel out the passwords for the 320 drive?  While it shouldn't matter, it might be the case the BIOS is only supporting one drive at a time.


          Otherwise sounds like some incompatibility or bug that Intel need to look into.





          • 2. Re: Intel 520 SSD can't set password

            I have this problem too, I have a thinkpad x61 when I try to set the password in the bios it tries to set a password and returns a message password set after a reboot but there is no password needed to logon and entering into the bios again shows that no password is set so it is just not working, this is very important to me when I travel and as a fix I clone my old hd where this password can be set.

            can the drive be returned for a refund on this issue alone.




            • 3. Re: Intel 520 SSD can't set password



              In the UK you could return it for sure as it is sold with having encryption for security, if you can't enable that, then it isn't working as it has been advertised.


              Not sure about other countries.





              • 4. Re: Intel 520 SSD can't set password

                I'm hitting this problem in a Lenovo W520, which is my main office workstation. Now I'm getting flagged by our security software as not having the HDD password set. Seems like a pretty standard function that should just work.

                • 5. Re: Intel 520 SSD can't set password

                  Intel support couldn't help but I got the answer here it may work for you too!






                  • 6. Re: Intel 520 SSD can't set password

                    Yep, this worked for me too. Change BIOS SATA mode to compatibility, save, reboot, enter BIOS, and now password on SSD can be set. Save, reboot, enter BIOS, and change back to AHCI mode.

                    • 7. Re: Intel 520 SSD can't set password

                      THanks for the tip.  I was able to set the HD password by switching to compatibility mode, then back to AHCI. 


                      HOwever, I'm seeing another odd behavior on my Lenovo x220.  It will only accept my password on a cold start--when I reboot, it always give me the "wrong password" error.


                      I can live with this for now, but would appreciate it if someone from intel is looking into it.

                      • 8. Re: Intel 520 SSD can't set password

                        Yep, I've seen this too on a Lenovo W520. I thought it wasn't even supposed to ask for a password on warm reboot.

                        • 9. Re: Intel 520 SSD can't set password

                          Only get asked for password on cold start here Thinkpad X61, on reboot no password needed.


                          M have you tried leaving the bios in compatibility mode and rebooting to see if it asks for your password.