14 Replies Latest reply on Dec 11, 2012 1:09 PM by Jenik Pecka

    DN2800MT renders BIOS settings read only


      I configured BIOS and activated UEFI to boot debian testing. All worked as expected in the first place. I then played around with some BIOS parameters. Nothing special, all did function well.


      In the course of further testing I changed my boot medium (used another USB stick). Unexpectedly as a net effect of all tampering now *no* BIOS parameters at all can be altered anymore. That means any change on any BIOS screen is not saved permanently.


      The system still boots linux over UEFI without problems though.


      When trying to change some BIOS parameter 'changed' in yellow letters appears in the bottom line as expected. But when confirming 'save & exit' it takes extraordinary long time until the screen changes to the next step. That's strange. All changes are discarded then. I notice that when entering the BIOS screen for the next time.


      I had exactly the same symptoms with  another DN2800MT but after playing around for hours it all of a sudden worked again. Unfortunately I can't reproduce what of my uncounted try and error attempts to recover the board  was essential to heal it.


      With my current (still defective) board I tried to downgrade BIOS from MT0155P.BIO -> MT0151P.BIO with no effect.


      I tried to toggle BIOS Setup Configuration Jumper Block with no effect.


      Don't know what else to try.


      For me all this clearly seems to reveal a nasty BIOS bug.


      Why can't I simply clear/erase everything to some safe default in BIOS?


      I think an unconditional total reset of all BIOS parameters should always be possible with no dependency on the current state. Obviously BIOS developers for DN2800MT did simply forget to implement that.


      I also tried to disconnect BIOS battery overnight with no effect. The BIOS does not forget it's current adjustements. Only some 'bios checksum error' messages show up on screen and event log.


      Maybe somebody made some similar observations and knows any solution :-)