2 Replies Latest reply on Nov 13, 2012 2:49 AM by gabiz_ro

    Intel 4965AGN - Wireless drops out with Windows 7 until restart.

    dandandan

      Hi everyone

       

      I have a DELL XPS M1530.. I've upgraded to Windows 7 and tried various drivers.

       

      When i download anything with significant bandwidth the internet drops down in speed significantly and then eventually drops out completely.

      The only way i can get around this is to restart the machine and then i get connectivity again for a while.

       

      I have tried some tricks i've found on this forum i.e. trying different drivers, older ones, later ones, and the current one and i still can't get past it.

       

      I also saw the trick about making sure "ad hoc qos wmm" was disabled in the driver settings.. Still no joy.

       

      Has anyone managed to get this working? I've seen numerous posts on here about it and no real information from intel concerning a fix.

       

      Regards

       

      danws_

        • 1. Re: Intel 4965AGN - Wireless drops out with Windows 7 until restart.
          MBV2000@intel.com

          I understand that you have connectivity issues with your system.

           

          The information you have provided indicates that is very possible that you have a hardware issue, it is possible that the wifi adapter stop working properly, that is why when you update the drivers the issue persist, the recommendation on this case will be to contact the oem manufacturer for further assistance and request a test on your wifi adapter.

           

          • 2. Re: Intel 4965AGN - Wireless drops out with Windows 7 until restart.
            gabiz_ro

            I can say that I have same problem.

            Dell laptop too,but from what I search on net seems is not related to Dell but to 4965AGN and WPA AES.

             

            WEP and WPA TKIP works fine but provide just G speed.

             

            WPA AES works fine too and provide N speed,a great improve.But this works fine just a short time until connection hang.Windows or Proset tell network is connected but I can't even ping router or other PC.

            I need to turn off wireless (Fn+F2 on Dell) then disable wireless card in device manager,then enable wireless card in device manager and turn on wireless (Fn+F2) after that is working again for some time until connection hang again.

            Searching for Event ID 5002 or 5005 that appear in event log I can see many people have same problem with 4965AGN and AES encryption.

             

            Tested few drivers version from Intel and Dell too but problem persist.

            Only working driver seems to be the one provided by MS with Windows 7 but with that one seems like I get low speed on connection.

             

            Borrow some other vendor cards that works fine,changed 4965AGN with other 4965agn and problem still exist.

             

            Problem is with Intel 4965AGN and the drivers.

             

            Now option are:

            -change wireless card to other model

            -use it on WEP or TKIP (but only G speed)

            -use it wit MS Win7 drivers (some low connection speed)

            -use it with Intel drivers (good speed but annoying hangs)

            -wait for Intel to solve problem of drivers (that I think never happens,there was few occasions when they can do this but all drivers have same problem)