1 2 3 Previous Next 31 Replies Latest reply: Jun 25, 2012 3:47 PM by dislikeyou RSS

DZ77GA-70K - Few Questions / Issues

dislikeyou Community Member
Currently Being Moderated

Hello. I purchased DZ77GA-70K board but i havent yet built my pc.

 

I have a few questions that i would like to get answered until i start building.

 

1. This board does not have Virtu MVP but it has Virtu Universal. i dont know exactly the difference but will Virtu Universal allow me to use Intel Quicksync when i have monitor connected to the nvidia GPU?

 

2. This board has 4 pwm fan headers but will it also control 3 pin fans like ASUS boards does?

 

3. I have Antec 920 cooler, is it safe to connect the cooler to the CPU fan header. I am worried that it might be too much for the header to handle because 2 fans are connected to the antec pump and then the pump is connected to the CPU fan header? I had a ASUS Z77 board where both CPU fan headers died and the Antec 920 was connected to it but i dont know if it was just coincidence that it died or it was too much for it to handle so i would not like same thing to happen on DZ77GA-70K. I dont find on Antec page how much power it requires but i think 12V.

 

4. I downloaded the bios file .BIO and put it on the USB stick. then i will have to press F something (will check manual again what number it was) at boot to load the software and it will detect the USB stick so i just select the .BIO file to update bios, right?

 

 

I hope i will not have any problems with this board. Really interesting to test out a Intel board for the first time.

 

Thanks.


  • 1. Re: DZ77GA-70K - Few Questions
    addy711 Community Member
    Currently Being Moderated

    Just got my board a few days ago. I'm having some issues, I've had Intel boards in the past and they have been rock solid for me, hopefully Intel support will get the DZ77GA-70K there soon.

     

    1. Disappointed that the board doesn't support Virtu MVP espcially when other 7 series Intel branded boards are listed on Lucid's product list, and this is the top of the line board right now. That being said Universal doesn't work for me, when I installed it, it said that my board wasn't licensed for it and offered me a 7 day trial. After installing, it fails to load on startup and displays an error.

     

    2. From the manual : Fan speed control using voltage control (4-pin fan headers front, rear, and

    auxiliary) with selectable support in BIOS for 3-wire fans.

     

    I don't see anything relating to 3-pin fans in BIOS 0039. It's not even picking up RPMs off my 3 pin fans, PWM fan control works fine.

     

    3. I use an air cooler but I assume the pump you just wire via a molex or 3-pin connection to the power supply. And connect the Antec fans to the mobo headers. The CPU fan header can handle 2.0A the other 3 are rated for 1.5A.

     

    4. This is how I upgraded my BIOS before I installed windows, just put the file on a USB stick, then hit F7 to bring up the BIOS flash menu. I didn't have any problems, worked fine.

     

    Other issues I have is in device manger I have an exclamation mark error on "PCI Simple Communications Controller" I thought the Intel ME driver was for this, but I installed it and it didn't not make the error go away.

     

    Also Intel Desktop Utilities does not work, I just get a green spinning circle as it tries to load. Somebody in another post said this is caused by having UEFI boot enabled

  • 2. Re: DZ77GA-70K - Few Questions
    jemsurvey Community Member
    Currently Being Moderated

    I've been running this board for a week now.  I have a couple issues but mostly they are minor.  I have a 3 pin fan connected to the rear fan header and it picks up the RPM's no problem.  I installed the updated BIOS through windows with no problem.  I am using Intels liquid cooler connected to the CPU header as intended.

     

    My issues were with the USB 3 ports but I think for the most part I have it worked out.  My PS2 keyboard is not working with the PS2 port but I think it may be the keyboard.

     

    Overall I like this board and so far its been quite stable.

  • 3. Re: DZ77GA-70K - Few Questions
    dislikeyou Community Member
    Currently Being Moderated

    Thanks for reply.

     

    From what i understand, it should be able to control 3 pin fans from the bios using volatage control. That's good and i hope i will not get the same problem as you, with bios 0039.

     

    Seems there is alot of issues with this board then but its probably random, so i might get the same issues but maybe will not. Perhaps you have not spent so much time trying to fix them. I remember i saw people with ASUS boards having issues with Lucid being trial mode. iirc they got advice to change something in bios for the integrated graphics and the trial issue were gone.

     

    When i see all this problems i am just thinking that i should return this board and get ASUS again. But since it does not seem to be hardware related, Intel could fix the issues by releasing new bios. So i will use this board and hope i will have no issues or if i will have them, that intel will fix them soon.

     

    Intel should lowe the price of this board. It has similar price as ASUS Z77 Deluxe but you get less features, no MVP, "more issues". And about the BT and CIR. I would rather wanted more USB 2 ports, could have sent a USB 2 bracket like i got with my ASUS board because some of my USB 2 devices is not working properly when connected to USB 3 ports. Also the BT should been 4.0 instead of 2.1 but i dont care, i will not be using it anyway. And CIR. I don't know what i would use it for, but ok.

  • 4. Re: DZ77GA-70K - Few Questions
    addy711 Community Member
    Currently Being Moderated

    So I started another thread on my issues but thought I'd mention it here in case you might not see it. All the problems I listed are related to having UEFI boot enabled in BIOS. With it disabled everything is fine for me.

     

    Also checked back in BIOS for fan settings and there is a manual option and a slider for for maximum performance %. All my fans are directly wired to the P/S or PWM at the moment so can't comment on how extensive control on 3-pin fans are.

  • 5. Re: DZ77GA-70K - Few Questions / Issues
    dislikeyou Community Member
    Currently Being Moderated

    I have built everything and it works well except a few issues:

     

    1. Enabled UEFI boot, installed Windows 7 x64 using USB stick but cant boot it.

    The error is: "Reboot and select proper boot device or insert boot media in selected boot device and press a key"

    Apparently something needs to be disabled in bios. I will experiment later to find out what is causing this.

     

    2. Have issue with driver for IGP. Latest driver from Download Center is broken for me. Giving me a error: "this computer does not meet the minimum requirements for installing the software. So i installed it from Windows Update and now it is working but seems to be an older version.

     

    Anyone else downloaded the latest driver and have same problem?

     

    I downloaded Virtu MVP from lucid website. It works but is evaluation only since Intel did not license it for this board. It does not say 7 day trial or anything like that. Just shows evaluation so i have no idea how long it will last. But good that it works.

     

    3. I have a issue with the speaker connected to PC. It makes a high pitched noise like this Sony Vaio High Pitched Sound / Whine - YouTube, the noise goes away when i open Intel HD installer but as soon as i close it the noise goes away.. have you encountered similar problem?

     

    The same speaker were making an annoying noise on my old PC too, but not a high pitched noise. It was a bit of different noise that was probably even more annoying then this. Also connected them to my laptop but it did not make so much noise there. Odd issue that can be temporary fixed by opening Intel HD installer but i would like to fix it permanently.


    Should mention that when i use earphones there is no noise at all. Too bad that i don't have other speakers to try with.

     

    Generally i am satisfied with this board. 3 pin fans works well. I have 3 x Nexus Real Silent 120 1000 RPM fans. They spin at 630 RPM currently because the bios has auto set it to run at that speed. The Antec is connected to CPU fan header but bios reports it running at 630 RPM. I think that is incorrect but that is because the Antec fans are controlled by the Antec software and not by mobo. Antec software shows the fans spinning at 660-700 RPM so that one is correct. The fan control on this board is working very well

     

    Suggestion to Intel:

     

    Exclude:

    CIR - Who needs / uses this???

    BT - I don't see any point for this since a USB BT module is better anyway.

    USB 3 Bracket - The cable on this one is short and does not reach to the bottom of the motherboard where the USB 3 header is located so its useless for me.

     

    and lower the price of the board instead. Else people will keep buying ASUS, Gigabyte, Asrock because they get more features for similar price.

    Also fix the BIOS / UEFI Boot issues and this board will be great.

  • 6. Re: DZ77GA-70K - Few Questions / Issues
    jemsurvey Community Member
    Currently Being Moderated

    Hi,

     

    I get the same error when trying to install the graphics driver.  I assumed it must be because I have the IGP disabled in BIOS but maybe not since you are having the same problem.

     

    Yes, the cable on the USB 3 bracket is way too short.  I purchased a header extension cord and it works fine.

  • 7. Re: DZ77GA-70K - Few Questions / Issues
    dislikeyou Community Member
    Currently Being Moderated

    Now i noticed a problem with USB 3 ports. Hmm

     

    First i got an exclamation mark on Intel(R) USB 3.0 eXtensible Host Controller.

    It was showing "This device cannot start. (Code 10)"

     

    Then i rebooted PC and same error. Rebooted again and went into bios. Was checking if there was a setting for USB 3 but did not find any so i rebooted into windows and the error was gone.

     

    But now when i connect a USB 3.0 or USB 2.0 external HDD on front USB 3 port or the rear USB 3 ports i get warning: "A USB device has exceeded the power limits of its hub port."

     

    So i reboot and test to connect the USB 3.0 and 2.0 hdd's to to USB 2 ports and it works normally. But when i then move them to the USB 3 port it gives me same error as above.

     

    The off thing is, after i connect the hdd's to the USB 3 port and get that error about power and move them to a USB 2 port, then i also get a error: "USB 2.0 MTT Hub has exceeded the power limits of its hub port."

    hmm... so the only thing that works is to reboot and only use the USB 2 ports.

     

    Any solution? Now i'm maybe starting to regret that i bought a Intel board, more and more errors

  • 8. Re: DZ77GA-70K - Few Questions / Issues
    phil_l Community Member
    Currently Being Moderated

    Hi

     

    I've no problems with the USB3 ports, although not used any USB3 devices, but all USB2 devices work fine.  This is on a DZ77BH-55K which is essentially very similar to this one.

     

    Is the hard-drive self powered?  If not it may be trying to draw too much power.  It might have been okay on another computer but if it is at the very limit of what USB can supply and you have a different arrangement of hubs on this motherboard, or by chance have more devices drawing from the hub, it might now fail.

     

    Either way what I would suggest is disconnecting any USB connections made to the headers on the motherboard and then try again using the USB ports at the back.  If they are now working okay with no power warnings, it might point to a connector to a device or front facing USB port in your case having a short circuit or drawing a lot of power.

     

    Also there is a very new driver for Intels USB 3.0, so if you haven't already it might be worth downloading that.

     

    Regards

     

    Phil

  • 9. Re: DZ77GA-70K - Few Questions / Issues
    dislikeyou Community Member
    Currently Being Moderated

    Thanks. The rear USB 3 ports works. When i wrote my last message it did not work because i connected the HDD to front USB 3 port and then moved it to rear port but when i only connect to rear port without connecting to front first, then it works well.

     

    The front port was working on my ASUS board, don't know why it is failing on this board. I will try with the supplied USB 3 bracket and see if that one will work.

     

    Noticed a new issue i think. Open hardware monitor is reporting wrong CPU clocks.

     

    OHM.PNG

     

    and this desktop gadget shows wrong MHz, it was showing 4678 MHz once. It also jumps from 0-20% all the time. and the load on the cores is different and jumping up and down all the time. It was not like that on my old board.

     

    gadget.PNG

     

    Intel Desktop Utilities is showing wrong values too. For example that memory speed shows as 1333 MHz but its is 1600. And memory voltage shows as 0.720, i guess thats wrong, it is set to 1.5V in bios. Let's hope Intel will solve it.

     

    Edit: Solved the graphics driver issue.

     

    The graphics driver on the Download Center for this board is not correct one.

     

    I noticed in the setup it says:

     

    *  NOTE:  This document refers to systems containing the

    *              following Intel(R) processors:

    *

    *

    *     2nd generation Intel(R) Core(TM) i3 processor

    *     2nd generation Intel(R) Core(TM) i5 processor

    *     2nd generation Intel(R) Core(TM) i5 vPro(TM) processor

    *     2nd generation Intel(R) Core(TM) i7 processor

    *     2nd generation Intel(R) Core(TM) i7 vPro(TM) processor 

     

    My i7 3770k is 3rd gen, so i got suspicious that it is the wrong driver. I chatted with Intel support and got confirmed that it was the wrong link.

     

    He told me to download this: Download Center , thats the Intel HD 4000 driver that is located at Download Center > Graphics > Processor graphics > 3rd Generation Intel Core....... so it is not located on the motherboard drivers page.. another issue solved

     

    Got an answer for the UEFI boot issue. Apparently Intel disabled ability to use UEFI boot on HDD's less then 3TB.. hmm i don't know if true. But very strange. UEFI boot should work on 120gb like it does on ASUS boards. Anyone could confirm this?

  • 10. Re: DZ77GA-70K - Few Questions / Issues
    dislikeyou Community Member
    Currently Being Moderated

    I have found a way to use full version of Virtu MVP on this board.

     

    The software will be in evaluation mode and some functions will be grayed out because Intel has not licensed it.

     

    So do this to make it full version:

     

    Download Virtu MVP software from here: ASRock > Products > Motherboard > Z77 Extreme9 > Download

    It will ask you to restart PC but don't restart yet.

    Download this file: Download gpuEnumerator.dll from Sendspace.com - send big files the easy way

    Move it to: C:\Program Files\Lucidlogix Technologies\VIRTU MVP or C:\Program Files (x86)\Lucidlogix Technologies\VIRTU MVP

    Restart PC.

     

    Now all functions in the software is activated and the about tab does not say evaluation mode.

     

    MVP-A.png

     

    Note that you can't download the latest version from lucid site because that one can't be changed to full version. It must be downloaded from a motherboard manufacturer, a motherboard that has lucid MVP license.

     

    Sorry if this is not allowed/legal to be posted here. I will remove it if needed. Should work on all Z77 and Z68 motherboards that has lucid universal.

  • 11. Re: DZ77GA-70K - Few Questions / Issues
    Yuriy Smirnov Community Member
    Currently Being Moderated

    I have the same issues with unknown PCI device and virtu.

     

    Virtu from intel support site won't install on my PC, virtu from lucid site have some error.

     

    it says:Runtime error (at 44:708) SWbemObjectSet: Invalid parameter.

    from ASRock site the same error

     

    don't know what to do...

  • 12. Re: DZ77GA-70K - Few Questions / Issues
    dislikeyou Community Member
    Currently Being Moderated

    Try to install all Visual C++ redistributables and run Direct X web updater. If that does not work then i guess you will have to re-install Wndows.

     

    What motherboard do you have?

    Are you sure UEFI boot is turned off in bios?

  • 13. Re: DZ77GA-70K - Few Questions / Issues
    Yuriy Smirnov Community Member
    Currently Being Moderated

    I've turn off UEFI and everything worked for me perfectly! Thank you!

    I have DZ77GA-70K.

    I have gtx 570 and core i7-3770k. gtx570 +i7 is faster than i7+virtu (gtx570).

  • 14. Re: DZ77GA-70K - Few Questions / Issues
    dislikeyou Community Member
    Currently Being Moderated

    Can you tell me one thing. Have you tried to install Windows 7 or 8 using UEFI mode and could you boot it with UEFI boot enabled?

     

    Did you install virtu mvp or universal? I think that universal does not have the v-sync thing so MVP should be better. Some people has reported bugs with virtu so for some games it is better to turn it off.

1 2 3 Previous Next

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points