5 Replies Latest reply on May 31, 2012 11:52 AM by mwaughex

    Build SCC-Linux with kernel 3.x

    devendra.rai

      Hello All,

       

      My application uses the features provided in the C++-11 standard, which require recent versions of gnu tool chain (4.6.x) and matching glibc libraries. In addition, I require few more features that the default SCC kernel does not have.

       

      I borrowed the starting steps from the Intel's document here: http://communities.intel.com/docs/DOC-6869

       

      However, the document is old, and patches Linux kernel 2.6.37 (Feb 2011 release IMO). I could not find a more recent document.

       

      Starting with the most recent buildroot version available, I manually tried to patch the files from the "patches" folder that Intel has provided in its SVN.

       

      I could make reasonable progress till I came across Intel supplied folder "sccLinux/buildroot-2011.05/board/intel/scc" which contains lot of patches to the kernel. Obviously, these cannot be directly applied to the new kernel (3.3).

       

      I also found a few bugs with the build (kernel v. 2.6.37, "No acceptable version of m4 found in $PATH"), which turns out to be a known bug. I was expecting the Intel's patches would have fixed it.

       

      In addition, the configuration file "sccLinux/buildroot-2011.05/board/intel/scc/linux-2.6.37.config" contains a line:

       

      CONFIG_INITRAMFS_SOURCE="/home/jbrummer/Projects/buildroot-2010.11/output/images/rootfs.initramfs"

       

      which, I believe, will cause a build failure.

       

      I have not scrutinized every file in "sccLinux/buildroot-2011.05/board/intel/scc/", but I suspect that there will more of such issues.

       

      Can anyone at Intel or the community help? Also, I have only a remote access to SCC.

       

      Would appreciate any ideas.

       

      Thanks a lot.

       

      Best,