1 Reply Latest reply on May 10, 2012 3:17 AM by Medusa22

    DZ77BH-55K various issues....

    Medusa22

      I just got my DZ77BH-55K mobo and got a few issues after installation. I run Win7 Ultimate 64 and 3770K. Bios 0070.

       

      1- Intel express install CD doen't see my MB as an Intel one, I get "No components for this motherboard" in the main window, installed drivers manually, but still this is annoying. Intel Desktop Utility doesn't work either, it run endlessly without showing anything.

       

      2- Everytime I boot after modifications in the bios, I get a CMOS Checksum error message.

       

      3- I get an unknown "PCI simple communication controller" in the device manager even after installing the MEI driver (ID : PCI\VEN_8086&DEV_1E3B&SUBSYS_20408086&REV_04). Could not find any solution here.

       

      4- Can not get the lucid Virtu working, the software stops working at launch.

       

      5- The Windows WEI can not complete, and I can not get the rating for my computer, this is the first time I get this issue out of a lot of PC's I am running with Win 7.

       

      All in one, this is a nice mobo on paper, nice design, quality components, but this is the very first time I get so many issues on a motherboard, so this is quite disapointing, I must admit I am strongly thinking about going back to Gigabyte or Asrock.

      Any help would be useful, it is the first time in 10 years I can not find the solutions on my own.

        • 1. Re: DZ77BH-55K various issues....
          Medusa22

          Problem solved, two main issues:

           

          Make sure you leave the "boot from UEFI" unchecked, as this leads to :

           

          - unknown PCI simple communication controller, in the device manager

          - prevents the express install CD to recognize the motherboard

          - prevents the Lucid Virtu software to work

          - freezes the Microsoft WEI execution

          - blocks the execution of the Intel Desktop Utilities

           

          All these problems went away just with unchecking the "boot from UEFI" in BIOS. This is a bit odd, since this is normally required to boot from 2.2+TB HDDs, so people who want to install their OS on this kind of HDDs will lose some important functions. Maybe Intel should look into it for future BIOS releases.

           

           

          CMOS Checksum error message was due to an corrupted flashing of the board (0057 to 0070), this is strange as well since most of the functions of the board were working, except the fans were running full power and the message at boot. I never saw a BIOS that worked after a corrupted flashing (no idea how that could happen), it either works or not, but at least the message was for some reason. I reflashed the board with the same bios and everything recovered.

           

          Thus I can give an excellent rating to the board despite a few minor issues. Excellent work Intel, a bit more work on the BIOS will make it near perfect product, finally able to compete with the best Taiwanese boards.

           

          +

           

          Excellent stability, very nice layout, superb fan settings in bios, nice uefi interface, excellent features for the money, simple and classy product.

           

          _

           

          One more SATA port on board would be useful (the eSATA is shared with the chipset's controller, that leaves only 5 Intel SATA on board).

          Voltage setting in the BIOS is not very friendly and a bit odd to use.