2 Replies Latest reply on May 7, 2012 1:56 PM by minerat

    Bootutil to update firmware on quad port pro1000pt (exp19404pt)


      I'm trying to use the latest bootutil to update the firmware on this card and simply can't.


      I see the ports listed:

      Port Network Address Series  WOL Flash Firmware                    Version
      ==== =============== ======= === ================================= =======
        1   001517C47B12   Gigabit N/A FLASH Unknown
        2   001517C47B13   Gigabit N/A FLASH Unknown
        3   001517C47B10   Gigabit YES FLASH Unknown
        4   001517C47B11   Gigabit N/A FLASH Unknown
        5   842B2BAA5A3A   Gigabit YES LOM,PXE


      but when I try to update using BOOTUTILW64E.EXE -nic 1 -restoreimage -file=bootimg.flb, I get "ERROR: Failed processing FLB file for port 1".  I've copied bootimg.flb into the directory with the utility.  For the hell of it, I tried saving the existing image, which appears to succeed but doesn't produce a file.  I need to get the firmware updated to troubleshoot an issue with these cards in new dell R720s.

        • 1. Re: Bootutil to update firmware on quad port pro1000pt (exp19404pt)

          First, did you uninstall PROSet and run the bat file to install the driver used by the utility? 


          I am asking because the utility and PROSet use a driver that could cause problems if the driver version does not match. That is the reason why the readmefirst.txt says to uninstall PROSet before installing the uitlity.


          I am guessing you probably did the installation, but I wanted to verify that you did it. One caveat, if you run the install from command prompt without admin rights, the driver file will not get copied. Then you could be using the wrong driver.


          Second, the restoreimage option only works to restore a previously saved image that is in the NIC format. That option does not work with the flb file. The command to use would be BOOTUTILW64E.EXE -nic 1 -up=pxe -file=bootimg.flb. The example used pxe, but you could substitute another image type such as iSCSI or efi64 if that is the image you were trying to install or upgrade.


          Third, since the version is showing up as unknown, I suspect that the flash is disabled on the adapter. Try this command to enable the flash: BOOTUTILW64E.EXE -nic 1 -FE


          If none of the above works, make sure you using the contents of the latest webpack labeled version 17.1. I can recall having some issues when using the earilier versions.


          Another thing you could try if nonthing else works.Create a boot dos device and use the dos version of the utility.


          I hope something above helps.Let me know what you find.


          Mark H

          • 2. Re: Bootutil to update firmware on quad port pro1000pt (exp19404pt)

            Thanks, I was just off on the syntax with up and file parameter.  It may also have needed to be flash enabled - I did that before I posted the thread.  It worked for this NIC, I'm sure it will work tomorrow for the other 3 I need to update.