7 Replies Latest reply on Apr 23, 2015 4:53 PM by R-Team

    "This device cannot start. (Code 10)" for Intel 82567LF




      I seem to be having some trouble with my wired network adapter built into my DX58OG motherboard.


      I'm on Windows 7 64bit and in Device Manager under Network adapters > Intel(R) 82567LF Gigabit Network Connection I get the message "This device cannot start. (Code 10)".


      This happened suddenly earlier today. My PC did crash but this shouldn't have killed the adapter. Anyway I've tried the following:



      Nothing seems to work. Do anyone have any ideas?





        • 1. Re: "This device cannot start. (Code 10)" for Intel 82567LF

          Have there been lightning storms in the area and is your PC fully protected with a surge suppressor that includes the phoneline/DSL cable? Does Intel Desktop Utilities still show the onboard LAN as being enabled? I assume you've tried loading BIOS default values? Was there any overclocking going on at the time of this error (the golden rule should be to restore defaults whenever problems arise and see if that makes them go away)? Intels latest PROWIN64 drivers should do the trick - you can get them under downloads for networking (or is it Ethernet) hardware and the one package includes drivers for a huge range of hardware.

          1 of 1 people found this helpful
          • 2. Re: "This device cannot start. (Code 10)" for Intel 82567LF

            Thanks for the reply. I just turned on my computer to try what you suggested but it's magically started working!


            If it stops again I'll be back here to give your ideas ago.


            Thanks a lot.

            • 3. Re: "This device cannot start. (Code 10)" for Intel 82567LF

              Glad to know it's 'magically' started working again.


              You may also want to double check your Antivirus software is up to date because these sorts of problems don't just happen for no reason at all and unless you find the true cause, it may well crop up again.

              • 4. Re: "This device cannot start. (Code 10)" for Intel 82567LF
                Matt Jones

                Wow what a coincidence. Anyway I am having the same issue as nojacko for the same adapter. I get (code10).


                I have Windows 7 64bit and I updated the driver to the latest available using PROWin64. Unlike nojacko I haven't been able to get it to work. I have tried uninstalling the driver, restarting, installing the updated drivers etc with no success.


                I was a victim of a lightning storm which led my PC to crash and I had to do a clean windows installation because my OS became corrupted with lots of driver errors - was hard to tell. However I decided to do a clean install of Windows 7 again to solve the issue and everything is back to normal except the Ethernet Adapter. The ethernet adapter lights up as customary with "green light" but does not flash - "no internet connection". I go to the device manager and I get (code 10). My modem does not "detect" any connection to my PC as customary signaled by a "light" when connected to my PC. My modem however works perfectly with the computer I am using at the moment and also worked flawlessly with my computer before the incident.


                So, I am wondering what the issue might be? My adapter fried? Any way to tell for sure?


                I'll appreciate any help.

                • 5. Re: "This device cannot start. (Code 10)" for Intel 82567LF

                  The lightning may be the cause but with good diagnostic tooling it is hard to say. You could check the windows event log if there are more details why the on-board nic doesn't want to start.

                  Disabling the on-board network adapter in the BIOS and installing a separate NIC card may be a cheap workaround.


                  If you have a spare partition you can try a trial version of win8 as an alternative to your clean win7 installation, but I think that will also give code 10.

                  • 6. Re: "This device cannot start. (Code 10)" for Intel 82567LF
                    Matt Jones

                    Thanks for the reply.


                    I disabled the on-board adapter through the device manager and I was able to restart without the "freeze on load" that I had before only when I tried to restart. A very common issue when there is a driver-hardware issue. There was never an issue with proper shutdowns. So I think that is a good indicator of where the issue resides.


                    I have a Rosewill RNX-N2X - a wireless ethernet adapter which I am using as of this very moment and is working perfectly and I am getting an internet connection from my network. It's a USB device that I bought 1 year ago in case of an issue such as this one.


                    Things get interesting when I tried using the RNX-N2X using the USB hubs on the back of my system. I got the same issue (Code 10). Surprisingly when I tried connecting the device using my front USB hubs the device worked perfectly. This might not be in any way related but it's hard to tell if there is something going on back there. I am scratching my head on this one.

                    • 7. Re: "This device cannot start. (Code 10)" for Intel 82567LF

                      I had the same issue.


                      Oddly, if I uninstalled the driver and then "found new hardware" it would work again, even after a reboot.  However, if I turned off the computer, the LAN Adapter would fail again; requiring a repeat of the uninstall step.


                      I solved it by updating the BIOS, updating the Chipset, and then updating the LAN drivers.