1 2 Previous Next 16 Replies Latest reply on May 8, 2012 11:14 AM by PC_buff

    DZ77GA-70K driver


      third clean install on this board, i've done both now with the board on the bench and minimal ram and addon cards installed.  PCI Simple Communications Controller, 2 of these show in the device manager. After chipset inf driver install 1 is left, after all other drivers (newest from intel download center) are installed it is still there. Intel support gave me an installation sequence for installing the drivers on a clean OS install...tried that with the same results.



      is the id it's showing... Panther Point MEI Controller #2 that looks like it might be attached to the usb 3.0...


      Any ideas on where to find a driver for this?

        • 1. Re: DZ77GA-70K driver

          gs274 wrote:


          Intel support gave me an installation sequence for installing the drivers on a clean OS install...tried that with the same results.

          So precisely what have you installed and in what order on what OS? There are alot of drivers available for this board and it is important it's done in the correct order (always with the chipset software installed first). Have you loaded BIOS default settings and saved out of there?

          • 2. Re: DZ77GA-70K driver

            win 7 x64


            All drivers are most recent release listed for the board from the download center in the following order.




            This beginning to feel like i'm installing a HP printer from 5 years ago. In 14 years of building professionally I've never seen anything that "required" a sequence for driver installation but those crap printers surely not a motherboard.

            • 3. Re: DZ77GA-70K driver

              I'd install the LAN drivers last as the MEI drivers are more important and other functions may depend on them. Have you installed the Bluetooth, WiFi and CIR drivers yet?


              I see you have add-on cards installed so if the above makes no difference, I'd try the fresh install again without those cards and with BIOS default values loaded/saved and only then, once everything is all showing up fine in device manager, shut down and power off, install your cards, boot into BIOS setup and disable your onboard sound (if that's not required) and then boot into Windows and install drivers for your Graphics card and sound card and the Lucid Virtu software. If you can't get a trouble free device manager with no add-on cards installed then post back with the details.

              • 4. Re: DZ77GA-70K driver

                not using wifi or the bluetooth, so the module is not installed, and the CIR driver installs with the mei iirc .

                • 5. Re: DZ77GA-70K driver

                  gs274 wrote:


                  not using wifi or the bluetooth, so the module is not installed, and the CIR driver installs with the mei iirc .

                  OK so the Wifi/Bluetooth Dongle isn't plugged in or used but as for the CIR I'm referring to this seperate CIR driver here: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19631&ProdId=3442&lang=eng&OSVersion=Windows%207%20(64-bit)*&DownloadType and its listed as one of the downloads for your board (seperate to the MEI driver).

                  • 6. Re: DZ77GA-70K driver

                    Now 5th install, board out of the box on the bench, no addon cards installed 1 dimm. Installed the OS, then installed chipset/mei/rst/usb3.0/cir/lan, still flagged device. Added audio/gpu and drivers in same order. Still flagged device, funny enough, the driver disk doesn't id the board as an intel board and neither does the automatic driver update. Going to rma and hope for new results with new board.

                    • 7. Re: DZ77GA-70K driver

                      Did you load and save BIOS setup default values? The fact Intels driver auto updates aren't working with it (yet) may simply be down to the fact it's so new and the team responsible for the auto driver update code haven't included the board yet. Before you RMA it, I suggest that you raise an official ticket with tech support to see what they have to say because I strongly suspect a replacement board will behave exactly the same way if you treat it the same.

                      • 8. Re: DZ77GA-70K driver

                        I have the exact same problem. Tried all the drivers I could find, but no luck so far.

                        • 9. Re: DZ77GA-70K driver

                          AED wrote:


                          I have the exact same problem. Tried all the drivers I could find, but no luck so far.

                          So you've tried EVERYTHING listed on the downloads for your board and OS on Intels website (not just drivers but including the Lucid virtu software). I don't understand much about that but clearly if you're getting a problem with a hardware ID relating to Panther Point hardware, that relates to the Z77 chipset itself so you need to ensure all drivers and even software that utilise or engage the chipset are installed. I dont know if gs274 mentioned whether the Lucid Virtu software was installed either.

                          • 10. Re: DZ77GA-70K driver

                            Yes, I have tried every possible driver and also the Lucid Virtu software you suggested. I'm starting to suspect something is wrong with my motherboard.

                            When I run CPU-Z and check the Motherboard tab, the manufacturer and model are blank. Also the three BIOS fields are blank. When I try to install software such as Intel Desktop Monitor or start the CD that came with the motherboard, I get an error about it not finding/requiring an Intel motherboard.


                            I will try to re-flash the BIOS and see what happens, if not I'll RMA the board.

                            • 11. Re: DZ77GA-70K driver

                              Yeah AED appears to have the same symptoms. No intel software or hardware identification tools id this board as an intel motherboard. I wonder if it has something to do with the 0035 flash.

                              • 12. Re: DZ77GA-70K driver

                                Yes, I have also updated to the latest 0035 BIOS. But right after the flash, I went into CPU-Z and looked at the motherboard information. All the fields were correct then, with updated date. Something must have happend since then. Should I try to do a recovery flash of the 0035 BIOS, or go back to the previous version through a normal flash? I already tried a normal flash of 0035, but it didn't fix it.

                                • 13. Re: DZ77GA-70K driver

                                  Just wanted to let you know I've sorted out my problem. It was the BIOS that was corrupt. I powered off and removed the jumper to clear/erase the settings. Now, the unknown device is gone and all is normal again. CPU-Z show the BIOS/ID strings and the Intel software installs fine now.


                                  Also, before I had several hardware devices showing in the Device Manager, that was disabled in the BIOS. The IR module, PS/2 port and some other devices. This also made me suspicious that something was not right.

                                  • 14. Re: DZ77GA-70K driver

                                    Hello Sir!


                                    I installed the same motherboard than you on the week-end. You have to install this for fix your uninstalled hardware "PCI COMMUNICATOR etc." ( sorry my windows is on french language.


                                    Go to intel for drivers and find that.


                                    Intel® ME: Management Engine Driver for Intel 6 & 7 Series Chipset-Based Desktop Boards



                                    I try to copy you the link but not sure it would works




                                    Good luck.


                                    After I installed that, i don't have any hardware left.


                                    Sincerely Dom

                                    1 2 Previous Next