2 Replies Latest reply: May 4, 2012 9:39 AM by bustaf RSS

PCIe No Longer Works on Z68 Chipset After Upgrading to Ivy Bridge Processor

FilmTraveler Community Member
Currently Being Moderated

I am running Windows 7 Ultimate 64-bit, on an ASUS P8Z68-V PRO/GEN3 motherboard based on the Z68 chipset, with BIOS  revision 3202 (absolute latest, specified to work with Ivy Bridge), and 16GB DDR3-1600 RAM. I was running it with an old  Intel Pentium G620 while I waited for the new Ivy Bridge processor to  come out. It finally arrived today and I installed it -- the new i7  3770K. Now PCI-e no longer works!

I had a PCI-e video card (a rather old but sturdy nVidia 7600GT), and it is no longer properly recognized by  Windows (even though it still outputs low-resolution VGA output). In  Device Manager, I see a yellow flag for "Other Devices > Unknown  device," which is obviously the PCI-e bridge. I attempted to "Update  driver" for it and during that process it's detected as "Xeon(R)  processor E3-1200 v2/3rd Gen Core processor PCI Express Root Port -  0151" but any attempt to install a driver for it fails.

Whenever I attempt to install the latest Intel chipset drivers from the support downloads from Asus, or attempt to install them manually using the package directly from Intel, I get the following error dialog:

Windows encountered a problem installing the driver software for your device

Windows found driver software for your device but encountered an error while attempting to install it.

Xeon(R) processor E3-1200 v2/3rd Gen Core processor PCI Express Root Port - 0151

An error occurred during the installation of the device

The driver installation file for this device is missing a necessary  entry. This may be because the INF was written for Windows 95 or later.  Contact your hardware vendor.

If you know the manufacturer of your device, you can visit its website and check the support section for driver software.

I know the new chips have some kind of new PCIe architecture, and so I wonder if it's related to that, and if so, how to fix this.

 

Have I neglected something? Is anyone else having a problem running a PCIe video card (or other PCIe  device) on this mobo once an Ivy Bridge chip is installed? Is anyone  getting their PCIe root properly detected by Windows at all?


  • 1. Re: PCIe No Longer Works on Z68 Chipset After Upgrading to Ivy Bridge Processor
    FilmTraveler Community Member
    Currently Being Moderated

    Update:

     

    I finally got the system to work properly. Here's how it worked for me.

     

    First what didn't work: I was unable to get the PCI-e to be detected through any method--I tried a hotfix provided by ASUS, tried installing older versions of the chipset (9.2.0.1021 up through 9.2.0.1030) which all installed fine but still failed to detect the PCI-e root port. Obviously my video card was not being properly detected because it was attached to a port which was not being detected either. I also tried selecting different default video ports in BIOS: iGFX, PCIe, and Auto, and none made any difference. I tried enabling LucidLogix in my BIOS, which also made no difference, and tried installing the LucidLogix Windows driver, which also failed because it detected no eligible hardware.

     

    So I finally just removed the video card and attached one of my two monitors to the motherboard's DVI port in order to run off the HD4000 integrated video chip. Then I tried reinstalling the latest chipset driver, version 9.3.0.1019, which I obtained from the Intel site. And what's strange is, I got the same error the first time I tried it, but after another try or two and a few reboots, it finally detected and worked! I should note for thoroughness that before doing any of this I installed the Intel MEI (Management Engine Interface) which was recommended by ASUS, but I have no idea whether this mattered to the final result because the PCIe device still failed to install several times afterwards and it wasn't until I removed the video card that it worked.

     

    I now had a properly-detected "Xeon(R)  processor E3-1200 v2/3rd Gen Core processor PCI Express Root Port -  0151" device in my device manager next to all the other system devices like USB/PCI/etc!

     

    I did not attempt to reinstall the nVidia video card to test whether this worked 100%, because I was intending to eventually switch over to the onboard graphics anyway.

     

    Related note: The onboard HD4000 graphics also failed to be detected for a while after I got the PCIe working, and attempts to install the Intel graphics driver resulted in "computer does not meet minimum requirements" error messages. However, after a handful of reboots, it apparently got detected by Windows 7 automatically, because it found it and installed the HD4000 driver all by itself just when I was about to set the computer on fire and give up. So if your onboard graphics chip isn't being detected, try doing "Scan for Hardware Changes" in Device Manager or running "Update Driver" on it and letting windows search online for the driver.

     

    I hope this helps somebody!

  • 2. Re: PCIe No Longer Works on Z68 Chipset After Upgrading to Ivy Bridge Processor
    bustaf Community Member
    Currently Being Moderated

    Hi
    For test Ivy, I  have buy  already an new ( MB  Z77)  is  added  to  an z68 I have already ,
    but thank lot for your participation
    and   your commented  experience  very instructive.
    Regards

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points