4 Replies Latest reply on Apr 16, 2012 2:04 AM by Flying_Kiwi

    D2500CC: does not REboot from USB Flash Drive

    MichaelTokarev

      Hello.

       

      I bought a D2500CC board to be used as a router device.  I planned to boot it off an USB Flash drive, into Linux.  This part works fine: the device recognizes the flash drive, boots from it, and all linux functionality is present.

       

      But the problem is that the device does not REboot.  On reboot, it shows black screen instead of the bootloader screen, and reboots in about 20 seconds, ad infinitum.  I can hit F2 while it initializes, and just save BIOS settings without changing anything (F10, Y) - after which it boots fine, but does not reboot again.  Obviously a router must be able to boot automatically without user intervention, so this is unacceptable behavour.

       

      There are no other bootable devices available.  SATA is turned off, network boot is turned off, there's no CD/DVD drive, just the single USB flash drive.  The same USB flash drive boots just fine on serveral other computers (including another small Intel board, D510something).  I tried another USB flash drive to the same effect - it boots only once only after saving bios settings.

       

      The boot loader is syslinux (extlinux), which works on alot of other devices.

       

      This is obviously a motherboard problem, since merely saving bios settings should not change the behavour.

       

      I tried the recently updated BIOS (0032 version), but it didn't change anything in this area.

       

      How can I enable the board to boot off USB flash drive correctly?

       

      Thanks,

       

      /mjt

        • 1. Re: D2500CC: does not REboot from USB Flash Drive
          MichaelTokarev

          Actually, this motherboard does not reboot from a hard drive too, not only from usb flash drive.  Only right after saving bios settings, or when freshly booted (powered on).  I _think_ this started after I updated bios to 0032 version, and the board was able to reboot from a HDD fine before, but I'm not sure.

           

          I've two such motherboards, and both shows the same - wrong - behavour, ie, both are unable to reboot properly.

           

          Meanwhile I found another thread here -- http://communities.intel.com/message/113963 -- which talks about different motherboard (also atom-based, older) and unability to boot linux.  The solution there was an updated bios that supports booting from non-FAT filesystems.  And I just tried booting and rebooting from another USB flash drive here, which is formatted as FAT32 - it appears to be able to reboot fine...  So it looks like a BIOS update is needed.  I'll try to dig further here.

           

          There's another issue with this (series of) boards.  Just a warning.  Don't enable boot optimization (usb or video or general - there are 3 separate menu items) IF your units are headless.  If you do, on the next boot the bios will claim that the previous boot attemt has failed (even if it was successful!), and will as if you want to enabe quick boot on the next reboot, waiting for a Y/N reply.  Buf if there's no keyboard and no monitor, you'll have to disconnect the unit and drag it to a place with monitor and keyboard, just to hit "N" key (hitting "Y" will result in the same question on the next boot).  This is especially useful when these boards have an ability to turn this quick boot off by holding Power button - hence without keyboard...

           

          Also, new (0032) BIOS added an option to swap the COM ports.  While for everything else in the BIOS, there's a choice between "Enable" and "Disable", this one options is like a check box, "[ X ]", toggled by hitting space bar.  Maybe I'm nitpicking, but it all shows just how raw the BIOS for these things is, and how much rough edges it has...

          • 2. Re: D2500CC: does not REboot from USB Flash Drive
            Flying_Kiwi

            If you have a look at the supported OS list here: http://www.intel.com/support/motherboards/desktop/sb/cs-008326.htm you'll see that your board isn't currently listed as supporting Linux. Does it REboot a supported OS fine? If so, you may need to change OS's in the mean time and ask Intel Tech Support (nicely) to provide full support for Linux on this board. If there are enough people who want Linux supported and it doesn't involve to much work, who knows, you may get a BIOS update which provides that compatibility. It isn't called the Innovation Series for nothing so my fingers are crossed for you.

             

            Let us know what Intel Tech Support has to say about it all (incl the BIOS 'inconsistentacy' you've found).

            • 3. Re: D2500CC: does not REboot from USB Flash Drive
              MichaelTokarev

              Thank you Flying_Kiwi for the reply.  I didn't know that an OS must be especially supported in order to use standard boot protocol, that's really news for me, I somehow thought that standards - established some 30 years ago - exists in order to help interoperability without requiring complete compatibility matrix between everything and everything...

               

              Meanwhile, I experimented with this motherboard a bit more.  Indeed, if I add an active MS-DOS (eg FAT16) partition, the motherboard reboots correctly.  Note it isn't sufficient to just change partition type, a "correct" filesystem has to be used on it too.  (What the heck BIOS has to do with partition tables and filesystem - this is what I don't know, it is none of BIOS business, none at all).

               

              So I used this workaround: I created a small /boot partition, formatted it as FAT16, marked it as active and used syslinux to install a bootloader into it.  Now the system boots fine.

               

              It is still dirty and hackish

               

              As for the complete linux support, that is very unlikely to happen due to graphics component used on these(*) boards.  It is the in-famous GMA500 line, known for lack of drivers on linux.

               

              BTW, where I can ask Intel for the support?

               

              (*)  All these issues exists on all 4 of the new Cedartrail mini-ITX motherboards from intel.  D2500CC, D2700MUD, D2800MT and some other model I forgot.  I bought the 3 mentioned mobos, first for a router and 2 other for thin clients, but returned the other 2 back due to lack of graphics drivers which is essential for a thin client.  D2500CC does not have graphics drivers for linux too, but it is less essential for a router, provided that other components works.  Apparently things aren't that simple...

               

              Intel, what you are doing?   These things are very nice, and linux is the first choice of an OS to run on them, fits very well, but...

              • 4. Re: D2500CC: does not REboot from USB Flash Drive
                Flying_Kiwi

                MichaelTokarev wrote:

                 

                Thank you Flying_Kiwi for the reply.  I didn't know that an OS must be especially supported in order to use standard boot protocol, that's really news for me

                There are MANY cases where people have had boot (and other) problems with unsupported OS's documented in these forums and in almost all cases they install a supported OS and the problem goes away. I'm glad you've found a workaround however I still suggest you contact Intel to formally (ie via letter or phone call to the contact details on their website - not these 'community' forums) request Linux be supported if you don't want to always have to go through this rigmarole every time you perform another installation. I don't know the ins and outs of why the issues happen, just that they do happen. Good luck with your dealings with Intel.