1 Reply Latest reply on Mar 29, 2012 12:32 PM by Diego_Intel

    WinXP Pro working with iaStor.sys 9.x and failing with 10.x, 11.x.

    matt352

      System: Asus Maximus IV Extreme-Z
      BIOS: 3203 (also 3103, 1004)
      Option ROM: 10.6.0.1091

       

      Problem: Intel AHCI/RAID driver iaStor.sys versions 10.x and 11.x fail with WinXP Pro SP3 (Stop 0x7B on OS boot; HDD unreadable on XP install). This includes the Asus support software. Version 9.x works with WinXP Pro SP3. This is a dual-boot system. No difference with controller in AHCI or RAID mode.

       

      iaStor versions 10.x and 11.x work with Windows 7 32-bit and 64-bit; haven't tried 9.x (no need).

       

      System/Boot drive is Hitachi 4TB formatted MBR and using under 2TB. Second drive is Corsair Performance Pro SSD formatted with MBR simple volume and cache volume by Intel RST 10.6 (I think) under Win 7 64-bit. Caching is disabled. Under WinXP RST 9.6 the system runs fine but the SSD simple volume does not mount; the RST UI sees the the SSD but complains it doesn't understand the later format.

       

      Intel provides the exact same driver for WinXP and Win 7 32-bit. Versions 10.x and 11.x work with Win 7 but fail on WinXP. iaStor.sys only depends on ntkrnlpa.exe and hal.dll; they load before iaStor.sys and every symbol imported by iaStor.sys is exported by ntkrnlpa.exe or hal.dll. All the critical device database and services registry entries are there. I can install the later drivers with the Windows driver update process, crash the system, boot Win 7 and literally paste in an older driver in XP's system32\drivers folder and boot OK. iaStor is loading when the boot fails (safe mode boot) since boot log generally fails then. The behavior is consistent and easily reproduced.

       

      I've used every configuration from fresh XP installs with no additions to a cloned production XP installation; same results. What am I missing?

        • 1. Re: WinXP Pro working with iaStor.sys 9.x and failing with 10.x, 11.x.
          Diego_Intel

          Hello,

           

          Intel(R) 6 series chipset controllers and Intel(R) Rapid Storage Technology 10.x versions have been mainly targeted for Microsoft* Windows* 7 editions. As a matter of fact most of the new Intel(R) Desktop Boards coming with the Intel(R) 6 series chipsets are not validated for mature operating systems like Microsoft* Windows* XP.

           

          In this particular case, your issues seems to be a compatibility problem between that operating system and the new I/O controller on your system. I suggest you to check dircetly with your motherboard manufacturer to see if they have certified this motherboard for that operating system and check with them directly for the configuration options and software versions that you should use.