2 Replies Latest reply on Mar 20, 2012 9:42 AM by vladk2k

    ISRT caching dissasociation problem

    vladk2k

      Hi

      My configuration is as follows:

      AsRock Z69 Pro3-M motherboard

      OCZ Agility 3 90GB SSD on port SATA3_0

      2x WD Caviar SE 160 GB in RAID1 configuration on ports SATA2_2 and SATA2_3

      Optical drive on SATA2_4

       

      Windows 7 SP1 64bit, all drivers up to date.

      The SSD is used part as a cache device (20 gB) and part as a system device with the OS on it. Performance is fantastic!

      http://i.imgur.com/fV1x9.png

      I came home yesterday to find my computer with a nice BSOD from volmgrx.sys. I rebooted the system and it started verifying the RAID1 array (it is not the first time this has happened). After it finished verifying, I noticed acceleration was disabled on my data volume. I went to Acceleration tab and it said

      Accelerated drive: Inaccessible. Disassociate

      Of course pressing dissasociate gives and error (Unknown error, operation could not be completed).

      In Oprion ROM the SRT volume appears as Disabled and can't enter Acceleration (No accelerated volumes)

       

      I've tried reinstalling Intel RST (version 10.8.0.1003) and updating my BIOS to 1.70 (The Option ROM displays 10.8.0.1003 as well).

       

      I've read here and elsewhere that my best option would be to reset the SSD to Non-Raid (Option 4 in Option ROM) but I'm affraid that this will break my windows installation and, in fact, would have to install windows on another drive just to get to re-enable Acceleration, afterwards I'll have to reinstall everything (I'm running a backup as we speak).

       

      Is there anything else I could do?

        • 1. Re: ISRT caching dissasociation problem
          allan_intel

          Hi there!

           

          In fact if you break or reset to non raid, your operating system will no longer be accessible. You will need to reinstall operating system from scratch.

           

          Thanks

          Allan

          • 2. Re: ISRT caching dissasociation problem
            vladk2k

            This is partly true.

             

            I went ahead and backed up everything complete with a system image (I don't want to sound like a fanboy baut Microsoft implemented a very solid backup system in Windows 7). I then went on to reset the SSD to Non-RAID. This did not break my operating system.

            I was able to log on and do everything, albeit with 20 gB of unused space at the end of the SSD.

             

            I was not able to reactivate caching on the SSD but that was to be expected (because I was running the operating system on it). I went ahead and did a temporary install of Windows 7 on another (external drive) that I happened to have around (lucky me) and reactivated SRT through the Rapid Storage Technology application. At this moment my original Windows 7 install did not boot any more (Boot manager missing).

             

            I suppose I could have tried only to fix startup with the repair disk, but I didn't want to waste any more time so I just went ahead and restored from my latest backup. Everything went along smoothly.

             

            Note for future readers that might bump into this problem: you still need the "F6 diskette drivers" for system image restoration. The wizard does not select the appropriate driver - you must navigate to IaStor.sys (or .ini, I don't remember) and select the "generic" SATA AHCI driver (it was first on my list).