4 Replies Latest reply on Mar 14, 2012 3:16 PM by tjg79

    DX58SO & Intel Rapid Storage Technology Driver


      I'm having an issue installing the latest updates on my motherboard. I was running Win XP Pro x64 and was unable to install the latest updates for the RAID RST & the LAN. I thought it was an os issue. I gave up on xp and did a clean install of Win7 Pro x64. I could install everything except the Intel Rapid Storage Technology driver. When the RAID driver was installed and the system rebooted, the os would freeze on the black Win7 start up screen. After reset button start, windows attempted to "repair" the issue, but was only successful if I used system restore to go back before the driver install. After many attempts trying every possible sequence order of install, I was able to get RAID driver to install one time without locking up, but the next driver installed, the LAN driver, caused the same issue. These driver installs are on clean install of the os before any updates are added and I've tried different hard disks to eliminate them from the equation.The system memory passes the windows memory test. Does anyone have any ideas? Intel tech support indicates that they are unaware of any issues. I suspect corrupted driver download or possible fault somewhere on the motherboard. Intel tech support indicated that if it boots, it's not the board. I've had the board bios set to RAID and AHCI, but that doesn't seem to be the issue. I've also done a recovery BIOS update to eliminate possible corrupted BIOS as an issue. If it's hardware related, it's the board. If it's software, it's drivers. I don't think it os related, because I'm having the issue with win xp pro x64 & win7 pro x64.



        • 1. Re: DX58SO & Intel Rapid Storage Technology Driver

          Hello tjg79,


          I see that you are having problems installing the drivers for your motherboard.


          At this point, I can confirm you that the drivers posted on the Intel(R) web site are working correctly and have been tested by us, the issue that you are experiencing seems related to a configuration problem or a hardware compatibility problem.


          First I recommend you to make sure that the RAM memory that is being used is compatible with your motherboard and processor. Please keep in mind that your processor only supports memory that is 1066MHz at 1.5v. If the memory is not within those specifications then it may be the cause of the problems.



          If the problem continues and you confirmed the the memory is fully compatible, please get in BIOS, load the defaults with F9, then change the SATA configuration for Advanced Host Controller Interface (AHCI) or RAID mode ( for Windows* 7) and then press F10 to save and exit.


          Proceed with a fresh install of the operating system, remember to run the INF file/ chipset driver before any other driver. Once you run that file you can continue with any order you prefer.





          • 2. Re: DX58SO & Intel Rapid Storage Technology Driver

            Thank you for the response Victor,


            I checked the memory compatibility for my board from the Intel DX58SO motherboard specs online and I am within specs for the board. My present memory is Corsair XMS3 DDR3 TR3X6G1600C9 1.65V Ver. 2.3 (PC3 12800). I've been running this memory with my i7-920 cpu for three years without issue. Also, the Intel specs indicate the DX58SO & i7-920 are compatible. I haven't seen any cpu/memory compatibility specs, but if they exist, I'm sure I'm within  spec.


            I've tried BIOS defaults for RAID & AHCI without success.


            Presently, I've just done a complete install of Win 7 Pro x64 with bios set for RAID and all the Intel drivers except the RAID: Intel RST driver. Everything works fine until I attempt to install the RAID: Intel RST driver.


            I always install the chipset driver first.


            Intel support has started a case number for my issue. I haven't heard anything yet. I let you know what they suggest.



            • 3. Re: DX58SO & Intel Rapid Storage Technology Driver



              After "discussing" this issue with several Intel tech support reps via chat and the telephone, a very astute Intel tech lady recommended I install the Intel RAID RST driver for the DX58SO2 & DX58OG boards running Win7 Pro x64. That driver version is The driver loaded without causing any issues and the RST utility appears to be fully functional on a very stable system.


              So, contrary to the official Intel position that the installed memory was not compatibile with the i7-920 cpu, that doesn't appear to be the case. The system is running fine and the bios indicates the memory is running at 1066Mhz.


              Per the CMTL tested memory list on the Desktop Boards, Intel Desktop Board DX58SO System Memory, The Corsair TR3X6G1600C9 memory was tested and passed on the DX58SO with a 3.2GHz CPU, probably the i7-960 which has the same memory spec as the i7-920. 




              The Intel tech rep indicated that this info would be reported to engineering for evaluation.



              • 4. Re: DX58SO & Intel Rapid Storage Technology Driver

                The Intel Desktop Control Center indicates the Memory Bus is at 1080MHz and the memory voltage is set to 1.54V.